openSUSE – KDE PIM 4.6.1

Die Entwickler haben das 1. Update von KDE PIM herausgebracht. KDE PIM 4.6.1 kann ab sofort auf openSUSE über ein Repo installiert werden. Es wurden 53 Fehler behoben. Die Entwickler überlegen, ob sie noch ein Update für KDE PIM 4.6 im nächsten Monat herausgeben wollen oder eher den Fokus auf KDE PIM 4.7 richten und mit dem Release von KDE 4.7 zu veröffentlichen.

In folgenden KDE PIM Anwendungen wurden die Fehler behoben (In Klammern sind die Anzahl der behobenen Fehler):

  • Akregator (1)
  • KOrganizer (28)
  • KMail2 (20)
  • Kontact (1)
  • KJots (1)
  • libkdepim (2)

Liste der behobenen Bugs seit KDE PIM 4.6.0: Bug Liste

Quelle: http://blogs.kde.org/node/4451

Leider ist noch keine Meldung zu KDE PIM 4.6.1 in den deutschen IT-Medien veröffentlicht worden. (Wahrscheinlich haben sie noch die Duke-Nukem-Forever-Brille noch auf :mrgreen: ) Ich muss gestehen, dass ich es auch erst gestern in der openSUSE-Mailingliste erfahren habe, dass KDE PIM 4.6.1 veröffentlicht wurde und direkt im Anschluss eine freundliche Mail an die openSUSE-KDE-Maintainer zwecks Paketupdate geschickt habe, sonst hätten wir wohl noch sehr lange auf KDE PIM 4.6.1 gewartet. ;-)

Zu openSUSE Tumbleweed: Es wird vorerst bei KDE PIM 4.4 bleiben. Aber ein Umstieg auf KDE PIM 4.7 wird mit der Veröffentlichung von KDE 4.7 zu rechnen sein.

Installation (YaST2):

Hinweis: Für andere openSUSE Versionen bitte anpassen. Falls die Einrichtung des KDE PIM-Repos bereits durchgeführt wurde, muss man lediglich nur ein Update via YaST2 oder zypper up durchführen. Es ist wichtig, dass ihr vor der Installation von KDE PIM 4.6 eine Sicherung von eurem KDE-Ordner ~/.kde4 macht, um jederzeit wieder auf KDE PIM 4.4 zurückgehen zu können.

[UPDATE 09.07.2011]
Die Installation von KDE PIM 4.6.1 setzt KDE 4.6.5 voraus: Anleitung zum Upgrade auf KDE 4.6.5
[/UPDATE 09.07.2011]

  1. YaST2 starten.
  2. Im Menü Konfiguration -> Repositories aufrufen.
  3. Auf Hinzufügen klicken.
  4. „URL angeben“ wählen und auf Weiter klicken.
  5. Repository-Name eingeben: KDE PIM 4.6
  6. URL des KDE PIM-Repo für openSUSE 11.4 eingeben: http://download.opensuse.org/repositories/KDE:/Release:/46:/kdepim46/KDE_Release_46_openSUSE_11.4/
  7. Auf Weiter klicken.
  8. Das erstellte Repository „KDE PIM 4.6“ auswählen und die Priorität auf z.B. 50 ändern.
  9. Auf Okay klicken, um die Verwaltung der Software-Repository zu schließen. Ggfs. den GPG-Schlüssel vom Repo importieren.
  10. In YaST2 dann auf Anzeigen -> Installationsquellen bzw. auf den offenen Tab Installationsquellen klicken.
  11. Auf der linken Seite das „KDE PIM 4.6“-Repo auswählen.
  12. Im blauen Textfeld auf Switch system packages klicken.
  13. Abschließend auf Akzeptieren klicken.
  14. Rechner neustarten und viel Spaß mit KDE PIM 4.6.1.

Installation (zypper):

  1. KDE PIM-Repo mit einem Alias hinzufügen:
    zypper ar -f "http://download.opensuse.org/repositories/KDE:/Release:/46:/kdepim46/KDE_Release_46_openSUSE_11.4/" "KDE_PIM_4.6"
  2. Priorität des KDE PIM-Repo erhöhen:
    zypper mr -p 50 "KDE_PIM_4.6"
  3. Upgrade von KDE PIM durchführen:
    zypper dup --from "KDE_PIM_4.6"
  4. Rechner neustarten und viel Spaß mit KDE PIM 4.6.1

Have a lot of fun! ;-)

VN:F [1.9.22_1171]
Rating: 10.0/10 (4 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
openSUSE - KDE PIM 4.6.1, 10.0 out of 10 based on 4 ratings
Dieser Beitrag wurde in openSUSE veröffentlicht und getaggt , , , , , . Ein Lesezeichen auf das Permalink. setzen. Sowohl Kommentare als auch Trackbacks sind geschlossen.

6 Kommentare

  1. Marcus
    Am 09. Juli 2011 um 09:22 Uhr veröffentlicht | Permalink

    Hoi,

    ich bekomme beim versuch KDEPim zu dup’en folgende Fehlermeldung:

    Computing distribution upgrade…
    21 Problems:
    Problem: nothing provides libqt4 >= 4.7.3 needed by akonadi-runtime-1.5.0.60git.1307899862-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by akregator-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kaddressbook-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kde4-kgreeter-plugins-4.6.5-620.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdebase4-workspace-4.6.5-620.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdebase4-workspace-4.6.5-620.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdepim4-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdepim4-runtime-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdepim4-wizards-4.6.1-1.1.i586
    Problem: nothing provides kdelibs4 >= 4.6.5 needed by kdepimlibs4-4.6.5-224.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdm-4.6.5-620.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kmail-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by knotes-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kontact-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by korganizer-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kwin-4.6.5-620.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by libakonadi4-4.6.5-224.1.i586
    Problem: nothing provides libqt4 >= 4.7.3 needed by libakonadiprotocolinternals1-1.5.0.60git.1307899862-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by libkdepim4-4.6.1-1.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by libkdepimlibs4-4.6.5-224.1.i586
    Problem: nothing provides libqt4-x11 >= 4.7.3 needed by kdebase4-workspace-4.6.5-620.1.i586

    Problem: nothing provides libqt4 >= 4.7.3 needed by akonadi-runtime-1.5.0.60git.1307899862-1.1.i586
    Solution 1: Following actions will be done:
    deinstallation of akonadi-runtime-1.5.0-3.3.1.i586
    deinstallation of plasma-addons-4.6.0-4.7.1.i586
    Solution 2: keep obsolete akonadi-runtime-1.5.0-3.3.1.i586
    Solution 3: break akonadi-runtime by ignoring some of its dependencies

    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):

    Hast du dazu eine Idee?

    Viele Gruesse
    Marcus

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: +1 (from 1 vote)
    • Am 09. Juli 2011 um 16:13 Uhr veröffentlicht | Permalink

      Hallo Marcus,

      sorry, ich muss mich entschuldigen. Es fehlte eine wichtige Info im Artikel, dass KDE 4.6.5 vorausgesetzt wird, weil es beim Bau von KDE PIM 4.6.1 mit dieser KDE-Version verlinkt wurde. Hier die Anleitung zum KDE-Upgrade: openSUSE – KDE SC 4.6.5

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Marcus
        Am 09. Juli 2011 um 20:41 Uhr veröffentlicht | Permalink

        Ok,

        dann soll die prio des PIM repos wohl auch zahlenmaessig einen niedrigeren Wert haben als das KDE_4.6 repo (z.B. 40), richtig?

        Ist zwar unwahrscheinlich, das es sonst zu Problemen kommt, aber theoretisch moeglich.

        Viele Grüsse
        Marcus

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        • Am 09. Juli 2011 um 21:43 Uhr veröffentlicht | Permalink

          Die Priorität gilt insofern für neue Pakete, wenn diese noch nicht installiert worden sind. Je höher die Priorität eines Repos ist, desto eher wird das Paket von dem betreffenden Repo genommen. In dieser Anleitung kommt das Upgrade einem Vendor- bzw. Herstellerwechsel gleich und gehe von der gleichen Zypper-Konfiguration aus, wie zur Standard-Installation von openSUSE.

          Wenn man aber für zypper eine abweichende Konfiguration in /etc/zypp/zypp.conf die Option solver.allowVendorChange = true gesetzt hat, dann würde zypper nach den Prioritäten des Repo und der neuesten Pakete gehen, hier sollten man dann die Priorität z.B. auf 45 erhöhen. Diese Option ist eigentlich nur für Leute gedacht, die wissen was sie tun, sonst hat man hinterher ein Misch-System. ;-)

          Gruß

          Sebastian

          VN:F [1.9.22_1171]
          Rating: 0.0/5 (0 votes cast)
          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
          • Marcus
            Am 11. Juli 2011 um 14:48 Uhr veröffentlicht | Permalink

            Ok, das heisst bei gleicher Prio werden Pakete die durch ein dup einen vendor change bekommen haben nicht mehr vendor changed, solage das nicht forciert wird. Neue Pakete würden, bei gleicher Prio, aus dem Repo genommen, das die höchste Version bereitstellt, richtig? Sind die Repos KDE_4.6 und KDE_PIM_4.6 denn darauf ausgelegt nebeneinander betrieben zu werden?

            Viele Grüsse
            Marcus

            VA:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VA:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
          • Am 13. Juli 2011 um 19:46 Uhr veröffentlicht | Permalink

            Hallo Marcus,

            wenn du magst, kannst du gleich KDE PIM eine höhere Priorität geben und einem potenziellen Problem aus dem Weg zu gehen. In 2 Wochen kommt ja eh KDE 4.7 und evtl. auch KDE PIM 4.7 im Schlepptau. ;-) Dann sind 2 getrennte Repos hoffentlich nicht mehr nötig.

            Gruß

            Sebastian

            VN:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VN:F [1.9.22_1171]
            Rating: 0 (from 0 votes)