openSUSE – proprietären Grafik-Treiber AMD Catalyst 14.3 Beta V1.0 als RPM installieren

AMD Catalyst 14.3 Beta V1.0 (fglrx 13.35.1005) wurde veröffentlicht und unterstützt Grafikkarten ab Radeon HD 5000 und höher. Das Skript makerpm-amd-14.3-betav1.0.sh steht ab sofort zum Download zur Verfügung und unterstützt openSUSE 11.4, 12.1, 12.2, 12.3, 13.1 sowie bis Kernel 3.13. Zum Packaging Skript wurde ein Patch hinzugefügt und unterstützt bis Kernel 3.14

Nachfolgende Release Notes von AMD zum AMD Catalyst 14.3 Beta V1.0:

Folgende Probleme sind im Treiber behoben worden:

  • [394848] – Xorg crashed playing AVI video file in VLC player or Parole player
  • [394705] – „Nexuiz – Demo3“ Ubuntu performance lower than Redhat
  • [394704] – „Nexuiz – Demo3“ Linux performance lower than Windows

Offene Probleme:

  • [390964] : Stuttering and poor performance after playing an OpenGL game for a several minutes on Ubuntu
  • [393377] : Terminal panel stops refreshing until there is movement from mouse cursor
  • [392546] : System hang observed while hotpluging the stereo display
  • [388835] : Corruption and system hang observed while running Sanctuary BM with TFD enable
  • [392552] : Enabling Overlay: StartX , the screen shows corruption

Link: AMD Catalyst™ 14.3 LINUX Beta Driver Release Notes

Folgende Steam-Spiele habe ich getestet und laufen mit diesem Treiber:

  • Amnesia: The Dark Descent
  • Cities in Motion 2
  • Crusader Kings II
  • Duke Nukem 3D: Megaton Edition
  • Euro Trucker Simulator
  • Europa Universalis IV
  • Half-Life 2: Deathmatch
  • Half-Life 2: Lost Coast
  • Hotel Miami
  • Project Zomboid
  • Shadow Warrior Classic Redux
  • Strike Suit Zero
  • Survivor Squad
  • Wargame Franchise Pack

Eine kleine Bitte habe ich: Wenn irgendwelche Probleme mit dem Treiber auftauchen, scheut euch nicht mir zu berichten (Ich nehme deutsche und englische Bugreports gerne entgegen). ;-) Ich werde versuchen, soweit es mir möglich ist, den gemeldeten Fehler zu reproduzieren. Zusammen mit den nötigen System-Informationen werde ich mich direkt an die richtige Stelle bei AMD wenden, um den Bug in der nächsten Treiber-Version beheben zu lassen. Danke schön. :-D

Für Benutzer älterer AMD Grafikkarten (Radeon HD Serie 2000 – 4000) wird dringend die Installation dieses Treibers abgeraten. AMD hat einen Legacy-Treiber zur Verfügung gestellt. Achtung: openSUSE 12.3 und 13.1 wird nicht unterstützt. Mehr Informationen zum Legacy Treiber: http://www.sebastian-siebert.de/2013/01/25/opensuse-amd-catalyst-13-1-legacy-treiber-als-rpm-installieren/

Downloads:

Installationsanleitung:
http://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber#Installation_via_makerpm-amd-Skript

Über das makerpm-amd-Skript

Das Skript makerpm-amd-14.3-betav1.0.sh ist sehr mächtig, robust und läuft vollautomatisch. Der AMD-Installer wird automatisch heruntergeladen, falls er nicht schon im Verzeichnis liegt. Zudem wird geprüft, ob die Grafikkarte vom Treiber unterstützt wird. Auf Wunsch wird nach dem Bau des RPM-Packages der fglrx-Treiber installiert.

Folgende Argumente können dem Skript übergeben werden:

-b Nur das RPM-Package bauen (Standard)
-c <type> Nur X-Server konfigurieren. Monitor-Typ: single = 1 Monitor, dual = 2 Monitore (Wichtig: Nur ausführen, wenn es Probleme mit der Standardkonfiguration des X-Servers auftreten)
-d Nur den AMD-Installer downloaden
-i Das RPM-Package bauen und installieren bzw. updaten
-kms <yes|no> Kernel-Mode-Setting (KMS) aktivieren oder deaktivieren
-nohw Hardware-Erkennung explizit ausschalten. (z.B. beim Bau in einer VM)
-old2ddriver <yes|no> den alten 2D-Treiber aktivieren oder deaktivieren
-r|–report erstellt ein Report und speichert diese in eine Datei namens amd-report.txt
-u|–uninstall entfernt AMD Catalyst restlos vom System. Zuerst wird das fglrx-Package (falls vorhanden) vom System deinstalliert. Danach werden vorhandene AMD-Dateien und -Verzeichnisse entfernt. Hinweis: Falls das Rebuild-Skript installiert wurde, wird es ebenfalls entfernt und das Initskript /etc/init.d/xdm wiederhergestellt.
-ur|–uploadreport wie Option –report nur zusätzlich wird der Report auf einem NoPaste-Service sprunge.us hochgeladen und gibt bei Erfolg den Link zurück.
-h Die Hilfe anzeigen lassen
-V Version des Skript anzeigen

Hilfe, es funktioniert nicht!

Bitte haltet folgende Regel ein:

  1. Bei der Eingabe der Befehle auf mögliche Tippfehler überprüfen.
  2. Möglicherweise ist die Lösung für das Problem im Wiki vorhanden.
  3. In Kommentaren lesen, ob eine Lösung zu einem Problem bereits existiert.

Wenn keines der o.g. Regel greift, dann könnt ihr mit eurem Anliegen an mich wenden. Damit ich euch helfen kann, müsst ihr erst vorarbeiten. Bitte ladet euch das Skript makerpm-amd-14.3-betav1.0.sh herunter und erstellt einen Report von eurem System in der Konsole:

su -c 'sh makerpm-amd-14.3-betav1.0.sh -ur'

Das Skript lädt das Report auf sprunge.us hoch und gibt anschließend einen Link aus. Diesen Link postet ihr in eurem Kommentar zusammen mit einer Beschreibung zu eurem Problem an mich. Ich werde mir euren Report anschauen und Hilfestellung geben, wo evtl. das Problem liegen könnte.

Feedbacks sind wie immer willkommen. :-)

VN:F [1.9.22_1171]
Rating: 10.0/10 (1 vote cast)
VN:F [1.9.22_1171]
Rating: +1 (from 1 vote)
openSUSE - proprietären Grafik-Treiber AMD Catalyst 14.3 Beta V1.0 als RPM installieren, 10.0 out of 10 based on 1 rating
Dieser Beitrag wurde in openSUSE veröffentlicht und getaggt , , , , , , , . Ein Lesezeichen auf das Permalink. setzen. Die Kommentare sind geschlossen, aber Sie können einen Trackback hinterlassen: Trackback-URL.

12 Kommentare

  1. Fran
    Am 21. März 2014 um 20:37 Uhr veröffentlicht | Permalink

    Hello!

    first of all, thanks for the great job you do with catalyst in openSUSE.
    I’m having problems running the script in my laptop, it says it’s not compatible, but I’ve never had any problems:

    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430] [1002:68e1]

    I’ve also uploaded the log from makerpm…. -ur

    http://sprunge.us/ShZg

    Thanks in advance.

    Regards,
    Fran

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Fran
      Am 21. März 2014 um 20:46 Uhr veröffentlicht | Permalink

      Ok, I don’t know why, but I’ve moved the script to a different folder and now it works :roll:

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  2. lutz
    Am 25. März 2014 um 09:06 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    Leider bekomme ich es partout nicht hin, dass der Treiber auch tut, was er soll – spätestens nach dem notwendigen Neustart funktioniert fgl_glxgears nicht mehr, manchmal zeigte es direkt nach der Installation die Zahnräder flüssig an.

    Versucht habe ich o.g. Beta, vorher die Version 13.12. Auch der Versuch alles zu deinstallieren und neu aufzusetzen war nicht erfolgreich, obwohl zum Schluss stets kam:

    ***
    Summary report:
    ============
    Kernel => 3.11.10-7-desktop
    Detected => RPM package
    Build => [ OK ]
    Install => [ OK ]
    ***

    aber einige Zeilen vorher auch so etwas:

    ***
    file /lib/modules/3.11.10-7-desktop/source/include/../arch/x86/include/asm/compat.h says:COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
    /usr/src/kernel-modules/fglrx/2.6.x /
    rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
    make: Entering directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop‘
    LD /usr/src/kernel-modules/fglrx/2.6.x/built-in.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_agp.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_debug.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_ioctl.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_io.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_pci.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_str.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_iommu.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_wait.o
    In file included from /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:198:0:
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function ‚KCL_GetInitKerPte‘:
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.h:89:9: warning: return makes integer from pointer without a cast [enabled by default]
    return PAGING_FAULT_SIGBUS_INT; /* Something bad happened; generate SIGBUS */ \
    ^
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2646:5: note: in expansion of macro ‚PGD_PRESENT‘
    PGD_PRESENT(pgd_p);
    ^
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.h:99:9: warning: return makes integer from pointer without a cast [enabled by default]
    return PAGING_FAULT_SIGBUS_INT; /* Something bad happened; generate SIGBUS */ \
    ^
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2649:5: note: in expansion of macro ‚PUD_PRESENT‘
    PUD_PRESENT(pud_p);
    ^
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.h:122:9: warning: return makes integer from pointer without a cast [enabled by default]
    return PAGING_FAULT_SIGBUS_INT; /* Something bad happened; generate SIGBUS */ \
    […]
    ***

    Zwischenzeitlich habe ich opensuse 13.1 auch nochmal frisch installiert, um irgendwelche Probleme auszuschließen, weil das Ganze mittlerweile eine Upgradeserie von 11.3 ->12.1 -> … -> 13.1 war. Auch passten die Kernelversionen nicht ganz, was aber nun auch behoben ist.

    Nun weiß ich echt nicht mehr weiter, hier also der Report:
    http://sprunge.us/UgPj

    Vielleicht kannst du mir ja helfen?

    Danke jedenfalls für die Mühe!

    PS: Sinn der Installation ist eigentlich „nur“ die Möglichkeit per Steam ein paar schöne Klassiker zu spielen, für Alternativen zum fglrx bin ich also auch aufgeschlossen :)

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • lutz
      Am 25. März 2014 um 09:08 Uhr veröffentlicht | Permalink

      PPS:
      anbei noch die Meldung von fgl_glxgears/fglrxinfo

      Using GLX_SGIX_pbuffer
      X Error of failed request: BadRequest (invalid request code or no such operation)
      Major opcode of failed request: 155 (ATIFGLEXTENSION)
      Minor opcode of failed request: 66 ()
      Serial number of failed request: 13
      Current serial number in output stream: 13

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
    • Am 27. Mai 2014 um 11:17 Uhr veröffentlicht | Permalink

      Hallo,

      die Warnungen kannst du ignorieren. Falls es noch Probleme mit dem Treiber gibt, installiere einfach den neuesten Treiber und lass es mich wissen, ob das Problem behoben wurde.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  3. Bernd Obermayr
    Am 10. April 2014 um 17:35 Uhr veröffentlicht | Permalink

    Hallo Sebastian,
    ich habe meine SuSE von 11.4 nach 12.3 gehoben. Dabei auch den neuesten Catalyst installiert. Es läuft soweit alles, d.h. es gibt keine gravierenden Probleme.
    Nur die von Dir früher schon mal erwähnten schwarzen Felder im Seamonkey (Mozilla) nerven etwas. Auch z.B die Scrollbalken oder Selektionen in Listen, in allen Anwendungen, haben eine seltsame Farbe (grünlich) was durch keine Einstellung wegzubringen ist (ich weiss nicht sicher ob das damit zu tun hat)
    Den Tip mit
    „/usr/bin/aticonfig –set-pcs-str=DDX,ForceXAA,TRUE“
    habe ich versucht, ohne Erfolg.
    Auch „nomodeset“ hat nichts geholfen.

    Bei SuSE 11.4 Evergreen mit einem älteren catalyst (ich glaube 13.8) hat alles super funktioniert.

    Ich glaube die Angaben über Kernel, Hardware etc stehen alle im Report, wenn Du
    noch Infos brauchst bitte fragen.

    Der Link: http://sprunge.us/VDAN

    Danke
    Bernd

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 27. Mai 2014 um 11:26 Uhr veröffentlicht | Permalink

      Hallo,

      danke für dein Feedback. Ich habe auf deine E-Mail geantwortet. Leider habe ich noch keine weitere Info von dir erhalten, ob das Problem nun behoben wurde. Ich freue mich, wenn du dich kurz meldest. Danke.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  4. Erik
    Am 10. April 2014 um 21:15 Uhr veröffentlicht | Permalink

    Hi, ich hatte den Treiber eine Weile unter Linux Mint 16 Petra 64bit installiert. Stockkernel und eine MSI 280x. Leider habe ich bei dem Spiel Metro Last Light öfters hangs gehabt, Xorg konnte ich dann nicht mehr neustarten. Mit dem stable release 13.12 ist das nicht passiert.

    Hast du das gleiche Problem?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 27. Mai 2014 um 11:27 Uhr veröffentlicht | Permalink

      Hallo,

      ich warte noch bis Metro Last Night im Sonderangebot gibt, dann lade ich es mir herunter und teste es auch mal auf meinem Rechner.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  5. Peter
    Am 29. April 2014 um 19:55 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    habe neulich dein Skript ein bischen umgestellt um den catalyst 14.4 zu installieren.
    Hat gut funktioniert auch mit dem kernel 3.14.1.

    grüße Peter

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: +1 (from 1 vote)
    • Michael
      Am 29. April 2014 um 22:39 Uhr veröffentlicht | Permalink

      Oh ja.
      Ein Skript für den 14.4 final wäre super :-)

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: +1 (from 1 vote)
  6. Andreas
    Am 17. Juni 2014 um 09:36 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    habe Opensuse 13.1 64 Bit KDE sobald Ich die Grafigkarten Treiber wie beschrieben installiere und neu boote dann erscheint immer das Terminal.Bei der deinstallation startet Opensuse wieder normal.Habe es auch über das Script installiert und das gleiche Problem.Ich weiss keinen Rat mehr.Bei Opensuse 12.3 hat der Treiber noch funktioniert. Ich weiss keinen Rat mehr.

    Grüße

    Andreas

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)