openSUSE – proprietären Grafik-Treiber AMD Catalyst 13.11 Beta V9.4 als RPM installieren

AMD Catalyst 13.11 Beta V9.4 (fglrx 13.25.18) wurde veröffentlicht und unterstützt Grafikkarten ab Radeon HD 5000 und höher. Das Skript makerpm-amd-13.11-betav9.4.sh steht ab sofort zum Download zur Verfügung und unterstützt openSUSE 11.4, 12.1, 12.2, 12.3, 13.1 sowie bis Kernel 3.12.

Der Beta-Treiber unterstützt jetzt von Haus aus Kernel 3.12. Daher habe ich meinem Patch im Packaging Skript zur neuen Beta-Version wieder entfernt.

Wie gehabt habe ich noch das störende Beta-Wasserzeichen in der unteren rechten Ecke entfernt.

Nachfolgende Release Notes von AMD zum AMD Catalyst 13.11 Beta V9.4:

Folgende Probleme sind im Treiber behoben worden:

  • [372656] : Resolves crash when resizing Konsole
  • [388325] : Resolves brightness adjustment issues
  • [388818] : Resolves kernel module compile failure when CONFIG_UIDGID_STRICT_TYPE_CHECKS is enabled
  • [388335] : Avoids the new GPL symbol acpi_bus_get_device for new kernel support
  • [386897] : Resolves system hang on resume from S4 with OpenGL screen saver running

Link: AMD Catalyst™ 13.11 LINUX Beta V9.4 Driver Release Notes

Eine kleine Bitte habe ich: Wenn irgendwelche Probleme mit dem Treiber auftauchen, scheut euch nicht mir zu berichten (Ich nehme deutsche und englische Bugreports gerne entgegen). ;-) Ich werde versuchen, soweit es mir möglich ist, den gemeldeten Fehler zu reproduzieren. Zusammen mit den nötigen System-Informationen werde ich mich direkt an die richtige Stelle bei AMD wenden, um den Bug in der nächsten Treiber-Version beheben zu lassen. Danke schön. :-D

Für Benutzer älterer AMD Grafikkarten (Radeon HD Serie 2000 – 4000) wird dringend die Installation dieses Treibers abgeraten. AMD hat einen Legacy-Treiber zur Verfügung gestellt. Mehr Informationen zum Legacy Treiber: http://www.sebastian-siebert.de/2013/01/25/opensuse-amd-catalyst-13-1-legacy-treiber-als-rpm-installieren/

Downloads:

Installationsanleitung:
http://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber#Installation_via_makerpm-amd-Skript

Über das makerpm-amd-Skript

Das Skript makerpm-amd-13.11-betav9.4.sh ist sehr mächtig, robust und läuft vollautomatisch. Der AMD-Installer wird automatisch heruntergeladen, falls er nicht schon im Verzeichnis liegt. Zudem wird geprüft, ob die Grafikkarte vom Treiber unterstützt wird. Auf Wunsch wird nach dem Bau des RPM-Packages der fglrx-Treiber installiert.

Folgende Argumente können dem Skript übergeben werden:

-b Nur das RPM-Package bauen (Standard)
-c <type> Nur X-Server konfigurieren. Monitor-Typ: single = 1 Monitor, dual = 2 Monitore (Wichtig: Nur ausführen, wenn es Probleme mit der Standardkonfiguration des X-Servers auftreten)
-d Nur den AMD-Installer downloaden
-i Das RPM-Package bauen und installieren bzw. updaten
-kms <yes|no> Kernel-Mode-Setting (KMS) aktivieren oder deaktivieren
-nohw Hardware-Erkennung explizit ausschalten. (z.B. beim Bau in einer VM)
-old2ddriver <yes|no> den alten 2D-Treiber aktivieren oder deaktivieren
-r|–report erstellt ein Report und speichert diese in eine Datei namens amd-report.txt
-u|–uninstall entfernt AMD Catalyst restlos vom System. Zuerst wird das fglrx-Package (falls vorhanden) vom System deinstalliert. Danach werden vorhandene AMD-Dateien und -Verzeichnisse entfernt. Hinweis: Falls das Rebuild-Skript installiert wurde, wird es ebenfalls entfernt und das Initskript /etc/init.d/xdm wiederhergestellt.
-ur|–uploadreport wie Option –report nur zusätzlich wird der Report auf einem NoPaste-Service sprunge.us hochgeladen und gibt bei Erfolg den Link zurück.
-h Die Hilfe anzeigen lassen
-V Version des Skript anzeigen

Hilfe, es funktioniert nicht!

Bitte haltet folgende Regel ein:

  1. Bei der Eingabe der Befehle auf mögliche Tippfehler überprüfen.
  2. Möglicherweise ist die Lösung für das Problem im Wiki vorhanden.
  3. In Kommentaren lesen, ob eine Lösung zu einem Problem bereits existiert.

Wenn keines der o.g. Regel greift, dann könnt ihr mit eurem Anliegen an mich wenden. Damit ich euch helfen kann, müsst ihr erst vorarbeiten. Bitte ladet euch das Skript makerpm-amd-13.11-betav9.4.sh herunter und erstellt einen Report von eurem System in der Konsole:

su -c 'sh makerpm-amd-13.11-betav9.4.sh -ur'

Das Skript lädt das Report auf sprunge.us hoch und gibt anschließend einen Link aus. Diesen Link postet ihr in eurem Kommentar zusammen mit einer Beschreibung zu eurem Problem an mich. Ich werde mir euren Report anschauen und Hilfestellung geben, wo evtl. das Problem liegen könnte.

Feedbacks sind wie immer willkommen. :-)

VN:F [1.9.22_1171]
Rating: 10.0/10 (2 votes cast)
VN:F [1.9.22_1171]
Rating: +1 (from 1 vote)
openSUSE - proprietären Grafik-Treiber AMD Catalyst 13.11 Beta V9.4 als RPM installieren, 10.0 out of 10 based on 2 ratings
Dieser Beitrag wurde in openSUSE veröffentlicht und getaggt , , , , , , , . Ein Lesezeichen auf das Permalink. setzen. Kommentieren oder einen Trackback hinterlassen: Trackback-URL.

33 Kommentare

  1. Am 23. November 2013 um 13:51 Uhr veröffentlicht | Permalink

    Hrmm. Ich habe gestern abend mit dem makerpm-amd-13.11-betav6.sh ein fglrx64_xpic_SUSE123-13.25.18-1.x86_64.rpm erzeugt und installiert; das makerpm-amd-13.11-betav9.4.sh erzeugt jetzt auch ein fglrx64_xpic_SUSE123-13.25.18-1.x86_64.rpm
    Ich bin verwirrt…

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 23. November 2013 um 14:00 Uhr veröffentlicht | Permalink

      Hallo Martin,

      verwirrte war ich auch zuerst. Aber ein direkter Vergleich mittels diff hat gezeigt, dass es Unterschiede gibt. Auch ein Blick in AMD Catalyst Control Center offenbart, dass ein Teil der Version zwar die gleiche ist, aber das Datum von gestern ist.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 4.0/5 (1 vote cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 23. November 2013 um 17:02 Uhr veröffentlicht | Permalink

        Danke. Dann ist AMDs Script kaputt, wenn es die Versionsnummer nicht erhöht. :-|

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        • Am 23. November 2013 um 19:17 Uhr veröffentlicht | Permalink

          Hallo Martin,

          ich habe das Skript um 15:16 Uhr nochmal aktualisiert, um die Revisionsnummer des Pakets zu erhöhen. Da Bruno Friedmann für das inoffizielle AMD-Repo eine neue „Nummer“ benötigt. :-) Wenn du das alte Skript löschst und es nochmal hier herunterlädst, sollte das fglrx-Paket ohne Probleme aktualisiert werden.

          Gruß

          Sebastian

          VN:F [1.9.22_1171]
          Rating: 5.0/5 (1 vote cast)
          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
  2. Torsten
    Am 23. November 2013 um 19:33 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    ich habe heute auf meinem Laptop (hat einen Radeon HD5470) openSUSE 13.1 installiert und dabei auch versucht den neuesten AMD Treiber zu installieren.
    Leider bleibt nach der Installation des Treibers der Bildschirm meines Laptops schwarz, sobald der Anmeldebildschirm erscheint. Dafür funktioniert aber der angeschlossene Monitor.

    Grüße
    Torsten

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  3. Denny
    Am 24. November 2013 um 18:49 Uhr veröffentlicht | Permalink

    Hallo Sebastian,
    unglaublich, aber der KDE – Crash (KDE SC 4.11.2) beim ändern der Größe des Konsolen-Fensters scheint wirklich behoben zu sein.

    Danke für Deine/Eure Arbeit.

    Denny

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  4. Pascal
    Am 26. November 2013 um 23:00 Uhr veröffentlicht | Permalink

    Hallo,
    habe das neuste Skript runtergeladen und ausgeführt. Installation hat auch problemlos funktioniert.
    Mein System: Laptop Acer Aspire 4820TG mit Radeon HD 6550M (Hybrid-GPU) /
    openSuse 13.1
    Obwohl ich im Bios nur die ATI aktiviere (Einstellung „discrete“) erscheint nur der
    Login-Hintergrund – aber nicht die Auswahl der User. Der Laptop hängt sich dann komplett
    auf. Starten kann ich im Recovery mode.
    Hier das Ergebnis des Debug-Outputs: http://sprunge.us/JbAg
    Und hier ein Auszug aus der kdm.log –> es gibt einen Segmentation fault:
    Initializing built-in extension RENDER
    Initializing built-in extension RANDR
    Initializing built-in extension COMPOSITE
    Initializing built-in extension DAMAGE
    Initializing built-in extension MIT-SCREEN-SAVER
    Initializing built-in extension DOUBLE-BUFFER
    Initializing built-in extension RECORD
    Initializing built-in extension DPMS
    Initializing built-in extension X-Resource
    Initializing built-in extension XVideo
    Initializing built-in extension XVideo-MotionCompensation
    Initializing built-in extension XFree86-VidModeExtension
    Initializing built-in extension XFree86-DGA
    Initializing built-in extension XFree86-DRI
    Initializing built-in extension DRI2
    Loading extension GLX
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
    Loading extension ATIFGLRXDRI
    (EE)
    (EE) Backtrace:
    (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x3d) [0x585acd]
    (EE) 1: /usr/bin/Xorg (0x400000+0x189839) [0x589839]
    (EE) 2: /lib64/libpthread.so.0 (0x7f533445c000+0xf9f0) [0x7f533446b9f0]
    (EE) 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (swlDrmFreeSurfaces+0x42) [0x7f533146a632]
    (EE) 4: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs114_atiddxDriCloseScreen+0x14d) [0x7f533143193d]
    (EE) 5: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs114_atiddxDriScreenInit+0x8eb) [0x7f5331430fdb]
    (EE) 6: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs114_atiddxScreenInit+0xe5e) [0x7f533142aa0e]
    (EE) 7: /usr/bin/Xorg (AddScreen+0x71) [0x43ceb1]
    (EE) 8: /usr/bin/Xorg (InitOutput+0x3df) [0x47d57f]
    (EE) 9: /usr/bin/Xorg (0x400000+0x2bfcb) [0x42bfcb]
    (EE) 10: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f53332cfbe5]
    (EE) 11: /usr/bin/Xorg (0x400000+0x2c501) [0x42c501]
    (EE)
    (EE) Segmentation fault at address 0x8a0
    (EE)
    Fatal server error:
    (EE) Caught signal 11 (Segmentation fault). Server aborting
    (EE)

    Woran kann das liegen? Was kann ich tun?
    Danke!!!
    Pascal

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 14:49 Uhr veröffentlicht | Permalink

      Hallo Pascal,

      der neue Treiber AMD Catalyst 13.12 ist nun draußen. Ggfs. ist dein Problem damit behoben.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  5. Dean
    Am 29. November 2013 um 00:29 Uhr veröffentlicht | Permalink

    Hallo Sebastian

    Habe vor zwei tagen auf meinem HP pavilion dv6 openSUSE 13.1 KDE installiert und habe es erst mal mit den free Radeon Treiber versucht aber das war nicht gut also beta Treiber war die einzige wahl.

    Eigendlich schien alles ok zu sein bis ich nicht von meiner 6755g2 zu meinr APU 6520g geweckselt habe esrt ist die Hellichkeits einstelung kapput gegangen was ich dann aber schnell mit diesen kommando gefixt habe: aticonfig –set-pcs-u32=MCIL,PP_PhmUseDummyBackEnd,1 .

    Zweites Problem wenn ich auf der 6520g bin und in den KDE desktop zum ersten mal log in machen fallen alle Effekte aus und das System arbeitet nicht richtig aber das komische ist wenn ich dann einen log out mache und wieder log in mache arbeitet alles normal.

    Wie kann man das Problem lösen?

    hier noch der report: http://sprunge.us/abiQ

    und danke für den Beta Treiber :D

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Stefan
      Am 12. Dezember 2013 um 23:24 Uhr veröffentlicht | Permalink

      Hallo Dean,

      ich habe auch den 6520G in meinem Laptop Toshiba Satellite L755D-123 verbaut, aber leider funktioniert das von Dir beschriebene Kommando (aticonfig –set-pcs-u32=MCIL,PP_PhmUseDummyBackEnd,1) zur Wiederherstellung der Backlightkontrolle bei mir nicht, weisst Du ob ich evtl. andere Parameter verwenden muss?

      Viele Grüße

      Stefan

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Stefan
        Am 12. Dezember 2013 um 23:39 Uhr veröffentlicht | Permalink

        Sorry Dean,

        hat sich erledigt, nach einem Neustart hat es geklappt.

        Vielen Dank für den Tip.

        Stefan

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 14:51 Uhr veröffentlicht | Permalink

      Hallo Dean,

      der neue AMD Catalyst 13.12 ist draußen. Kannst du bitte überprüfen, ob dein Problem noch besteht.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  6. Alexander
    Am 05. Dezember 2013 um 12:29 Uhr veröffentlicht | Permalink

    Einen Tipp habe ich noch, nachdem ich stundenlang auf Fehlersuche war:

    Wenn Dateien vom (13.1) X11-Repo installiert wurden (z.B. neuere X11-Versionen), so stürzt X11 mit Segmentation fault mit dem fglrx-Treiber ab.

    Erst nach Rückaktualisierung X11->13.1 OSS geht es.

    Hoffe, das hilft jemandem.

    Gruss Alexander

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 14:59 Uhr veröffentlicht | Permalink

      Hallo Alexander,

      das X11-Repo enthält immer den neueste grafischen X-Server. Das Problem an dieser Stelle ist, dass AMD nicht besonders schnell ist, um neue Grafiksystem zu unterstützen. Mit diesen Problemen muss man immer rechnen. Daher lieber beim originalen X-Server aus dem OSS-Repo bleiben.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  7. Am 07. Dezember 2013 um 20:43 Uhr veröffentlicht | Permalink

    Hi,

    vielen Dank für das Script funktioniert einwandfrei nur 2 Dinge stören mich etwas.
    mein U38N von Asus installiert opensuse nur wenn ich nomodeset und x11failsafe als option hinzufüge,
    nun nach einigem ausprobieren startet der AMD Treiber nicht mit der Option X11failsafe, ohne die Option startet der AMD Treiber wie er soll! warum das so ist hab ich nicht ergoogln können.
    sobal der AMD Treiber aktiv ist geht auch die Tastaturbeleuchtung nicht mehr, sobald ich mit X11failsave den AMD Treiber vom Starten abhalten funktionierts wie es soll. an was es nun genau liegt ???? keine Ahnung

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 15:20 Uhr veröffentlicht | Permalink

      Hallo Ulli,

      da gibt es ein Verständnisproblem. Der X11-Failsafe-Modus ignoriert jeden proprietären Treiber und nimmt dafür den Standard-Treiber von openSUSE. Das ist nur dafür gedacht, falls es massive grafische Probleme gibt, dass man wenigstens noch einen Fallback-System hat, um das Problem ggfs. zu beheben. Wenn man den fglrx-Treiber verwenden möchte, muss man in den normalen Modus gehen.

      Tastaturbeleuchtung?! Was genau sollte das sein? Meinst du die Backlight-Steuerung vom LCD-Monitor des Notebooks?

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  8. froschels
    Am 10. Dezember 2013 um 04:18 Uhr veröffentlicht | Permalink

    Hallo,

    ich habe openSUSE 13.1 (KDE) mit dem Catalyst 13.11 Beta 6 drauf. Kann ich eigentlich ohne weiteres mit deinem Skript auf Beta 9.4 updaten oder muss ich den alten Treiber vorher deinstallieren oder auf etwas achten?

    Ich habe nämlich mit dem aktuellen Beta 6 Treiber während des Systemstarts Grafikfehler. Das ist nicht weiter schlimm, da diese wieder verschwinden, sobald ich beim Login-Screen bin. Aber vielleicht behebt der Beta 9.4 diesen kleinen Schönheitsfehler auch noch.

    (Anmerkung: Den Grafikfehler hatte ich zuvor unter Linux Mint KDE 15 (Ubuntu 13.04/Kernel 3.8) mit dem Catalyst 13.4 Final nicht, aber schon seit dem ersten Test mit openSUSE 13.1 RC2 mit Catalyst 13.11 Beta 1)

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 15:21 Uhr veröffentlicht | Permalink

      Hallo,

      der neue Treiber ist draußen. Bitte auf diese Version updaten und mir kurz berichten, ob dein Problem damit behoben ist.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • froschels
        Am 04. Februar 2014 um 01:19 Uhr veröffentlicht | Permalink

        Hallo Stephan,

        ich habe den Catalyst 13.12 letztens auf meinem System installiert. Der Fehler ist aber nach wie vor vorhanden.

        Da aber der Rest des Systems super funktioniert, werde ich einfach warten bis ein neuer Final-Treiber erscheint.

        Grüße,
        froschels.

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        • Am 04. Februar 2014 um 10:25 Uhr veröffentlicht | Permalink

          Hallo,

          du kannst gerne auch nochmal den AMD Catalyst 14.1 Beta V1.3 probieren. Da sind jede Menge Fehler behoben worden.

          Sollte der Fehler immer noch vorhanden sein, benötige ich über das Skript ein Report von deinem System (Link bitte hier posten):

          su -c 'sh makerpm-amd-14.1-betav1.3.sh -ur'

          Gruß

          Sebastian

          VN:F [1.9.22_1171]
          Rating: 0.0/5 (0 votes cast)
          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
          • froschels
            Am 04. Februar 2014 um 13:13 Uhr veröffentlicht | Permalink

            Das Skript gibt bei der Installation des Catalyst 14.1 Beta 1.3 einen Fehler aus:

            Problem: Es können nicht beide Pakete, fglrx64_xpic_SUSE131-13.35.1005-1.x86_64 und fglrx64_xpic_SUSE131-13.251-2.x86_64, installiert werden
            Lösung 1: Rückaktualisierung von fglrx64_xpic_SUSE131-13.251-2.x86_64 zu fglrx64_xpic_SUSE131-13.35.1005-1.x86_64
            Lösung 2: Nicht nach der Installation eines auflösbaren Objekts, das fglrx64_xpic_SUSE131 = 0:13.35.1005-1 anbietet, fragen.

            Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie a(b). [1/2/b] (b): b
            Error: zypper could not install the fglrx64_xpic_SUSE131-13.35.1005-1.x86_64.rpm package [ FAILURE ]

            VA:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VA:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
          • Am 04. Februar 2014 um 14:44 Uhr veröffentlicht | Permalink

            Am Besten du entfernst den Treiber fglrx64_xpic_SUSE131-13.251-2.x86_64 in YaST/zypper und versuchst es nochmal.

            Gruß

            Sebastian

            VN:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VN:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
          • froschels
            Am 04. Februar 2014 um 16:25 Uhr veröffentlicht | Permalink

            Hallo,

            habe den Catalyst 14.1 Beta 1.3 nun installiert.
            Der Fehler ist nach wie vor vorhanden.

            http://sprunge.us/MIJV

            Grüße,

            froschels

            VA:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VA:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
  9. Stefan
    Am 12. Dezember 2013 um 23:00 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    mir sind auf meinem Toshiba Satellite L755D-123 einige Dinge mit dem Treiber aufgefallen:

    Nach dem „normalen“ Boot (kein vorheriger Suspend):
    1. Die Backlight-Kontrolle funktioniert über die Fn-Tasten und auch über den Schieberegler der Akkuüberwachung. Allerdings wird neben dem Schieberegler in der Akkuüberwachung immer 71% angezeigt, wohingegen das OSD (die beim Betätigen der Fn-Tasten nicht angezeigt wird) den korrekten %-Wert anzeigt (zum besseren Verständnis kann ich auch einen Screenshot nachreichen).
    2. Die Benachrichtigungsfunktion der Akkuüberwachung funktioniert nicht (weder Tonausgabe noch Meldungsfenster) und auch die festgelegten Aktionen (z.B. bei 10% in den Tiefschlaf versetzen) werden nicht ausgeführt.

    Nach Suspend (sowohl s2disk als auch s2ram):
    1. Die Backlight-Kontrolle funktioniert weder über die Fn-Tasten noch über den Schieberegler der Akkuüberwachung, OSD wird nur beim Schieberegler angezeigt (mit 0-100%) und der Prozentwert in der Akkuüberwachung steht ebenfalls konstant auf 71%.
    2. Die Benachrichtigungsfunktion der Akkuüberwachung funktioniert vollständig (Tonausgabe, Meldungsfenster und festgelegte Aktionen).

    Die Reports Deines Scripts habe ich auf sprunge.us hochgeladen
    Normal Boot: http://sprunge.us/jEDF
    Nach Suspend: http://sprunge.us/chUK

    Die erste Installation des Treibers habe ich über Yast mit der eingebundenen Repo (http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/) durchgeführt. Aufgrund der o. a. Fehler habe ich ihn dann wieder deinstalliert und nochmals mittels Deines Scripts installiert.

    Die oben beschriebenen Phänomene treten mit dem Standard-Grafiktreiber von OpenSuse 13.1 nicht auf. Muss ich evtl. noch irgendetwas der Standardgrafiktreiber manuell deinstallieren?

    Viele Grüße

    Stefan

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Stefan
      Am 12. Dezember 2013 um 23:38 Uhr veröffentlicht | Permalink

      Hallo Sebastian,

      die Backlightkontrolle habe ich jetzt durch das von Dean beschriebene Kommando wieder hinbekommen, zumindest provisorisch ohne OSD bei den Fn-Tasten und falsche/fixe Prozentangabe in der Akkuüberwachung. Ist zwar noch nicht perfekt, aber besser als nichts.

      Gruß

      Stefan

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  10. Michael
    Am 19. Dezember 2013 um 15:49 Uhr veröffentlicht | Permalink

    Es gibt einen neuen Catalyst :-)
    http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst13-12LINReleaseNotes.aspx

    Leider scheints mit neueren Kernels build-Probleme zu geben. Vielleicht kannst Du da was machen, Sebastian?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 20. Dezember 2013 um 21:55 Uhr veröffentlicht | Permalink

      Kann ich bestätigen, nach dem Installieren des (selbst gebauten) RPMs kommt ein Fehler beim Versuch das Kernel-Modul für Kernel 3.11.6 zu kompilieren. Kernel 3.7.10 (Überbleibsel von 12.3) scheint hingegegen zu funktionieren.

      Compiler-Fehlermeldung:
      /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.c: In function ‚KCL_ACPI_ParseTable‘:
      /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.c:999:5: warning: passing argument 1 of ‚(acpi_status (*)(u32, void *, void *))handler‘ makes integer from pointer without a cast [enabled by default]
      ((acpi_table_handler)handler)(hdr);
      ^
      /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.c:999:5: note: expected ‚u32′ but argument is of type ’struct acpi_table_header *‘
      /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.c:999:5: error: too few arguments to function ‚(acpi_status (*)(u32, void *, void *))handler‘
      make[3]: *** [/usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.o] Error 1
      […]

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 21. Dezember 2013 um 15:28 Uhr veröffentlicht | Permalink

        Hallo Joachim,

        das Problem wurde lokalisiert und mit dem neuesten makerpm-amd-Skript für AMD Catalyst 13.12 behoben. AMD hat da einen Bock geschossen. :-?

        Gruß

        Sebastian

        VN:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 15:25 Uhr veröffentlicht | Permalink

      Hallo Michael,

      jepp, ist nun mit dem neuen Artikel erledigt. :-)

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  11. Robert
    Am 20. Dezember 2013 um 16:33 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    ich würde mich auch für den neuen Catalyst interessieren. 8)
    Ich hatte (habe?) diverse grafische Probleme und erhoffe mir durch den neuen Treiber
    das dieser Bug siehe:

    https://www.dropbox.com/s/h7vvi1c36jbqdm8/20131214_191347.mp4

    behoben ist, dass der Mauszeiger nicht verschwindet wenn der Screensaver an ist, ist das auch ein Bug vom Grafiktreiber oder von KDE? :roll:

    Ich habe ein ATI Radeon HD 5800 Series.

    LG Robert :wink:

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 15:26 Uhr veröffentlicht | Permalink

      Hallo Robert,

      schau mal bitte, ob der neue Treiber das Problem behebt.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Robert
        Am 21. Dezember 2013 um 20:48 Uhr veröffentlicht | Permalink

        Guten Abend,

        Perfekt!

        Der neue Treiber hat das Grafik Problem verschwinden lassen. :wink:

        Das mit dem Mauszeiger besteht nach wie vor, kann aber natürlich auch an KDE liegen.

        Sebastian, du leistest echt super Arbeit mit dem Treiber, ich wollte mich bei dir dafür bedanken :)

        LG Robert

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        • Am 02. Januar 2014 um 11:30 Uhr veröffentlicht | Permalink

          Hallo Robert,

          frohes neues Jahr wünsche ich noch.

          Danke für dein Feedback.

          Wegen dem Mauszeiger würde ich in KDE die aktivierten Effekte einmal nacheinander ausschalten, womöglich macht ein KDE-Effekt dem Treiber zu schaffen. Ggfs. auch einmal das KDE-Theme wechseln.

          Gruß

          Sebastian

          VN:F [1.9.22_1171]
          Rating: 0.0/5 (0 votes cast)
          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)

Einen Kommentar hinterlassen

Ihre E-Mail wird niemals veröffentlicht oder weitergegeben. Erforderliche Felder sind mit * markiert

Sie können diese HTML-Tags und -Attribute verwenden <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*
*

:wink: :-| :-x :twisted: :) 8-O :( :roll: :-P :oops: :-o :mrgreen: :lol: :idea: :-D :evil: :cry: 8) :arrow: :-? :?: :!: