openSUSE – proprietären Grafik-Treiber AMD Catalyst 13.11 Beta V1 als RPM installieren

AMD Catalyst 13.11 Beta V1 (fglrx 13.20.16) wurde veröffentlicht und unterstützt Grafikkarten ab Radeon HD 5000 und höher. Das Skript makerpm-amd-13.11-betav1.sh steht ab sofort zum Download zur Verfügung und unterstützt openSUSE 11.4, 12.1, 12.2, 12.3, 13.1 sowie bis Kernel 3.11.

In eigener Sache: Ich möchte mich bei allen Spendern zur Förderung des Installationsskripts für den AMD Catalyst Treiber unter openSUSE wie auch den Erhalt des Blogs ganz herzlichst bedanken. Somit ist es mir möglich, diesen Blog weiterhin werbefrei zu halten. In der letzten Zeit habe ich nicht gerade wenige Angebote erhalten, über einen einfachen Blog-Artikel zu einem Produkt in Zusammenhang mit Linux in eigenen Worten zu schreiben. Erstens kommt für mich Schleichwerbung gar nicht in Frage und zweitens soll dieser Blog nicht mit irgendwelchen dubiosen Produkten zugemüllt werden. Es kann weiterhin via Flattr, PayPal, Überweisung oder auch per Post gespendet werden. Nochmal vielen Dank für eure Unterstützung. ;-)

Ab sofort habe ich die Unterstützung für openSUSE 13.1 RC1 eingepflegt und wurde von mir ausgiebig getestet. Kleiner Tipp: Sollte es beim Verschieben eines Fensters unter openSUSE 13.1 mit KDE 4.11.2 zum Tearing kommen, dann empfehle ich in der KDE-Einstellung der Arbeitsflächen-Effekte unter Erweitert die OpenGL-Einstellung für „Einzelbild-Zerreißen (Tearing) verhindern (VSync)“ auf „Bildschirm-Inhalt wiederverwenden“ zu setzen.

Zudem habe ich ein kleinen Bugfix für openSUSE 13.1 RC1 in das makerpm-amd-Skript integriert, dass ein Problem mit der inkorrekten Formatierung von /etc/SuSE-release in Zusammenhang mit dem Kommandozeilten-Tool lsb_release behebt (Siehe Bugreport #845262). Das Tool lsb_release kann dann die korrekten Daten zu openSUSE zurückliefern. Ohne diese Korrektur funktioniert die automatische Erkennung nicht mehr.

Wie gehabt habe ich noch das störende Beta-Wasserzeichen in der unteren rechten Ecke entfernt.

Nachfolgende Release Notes von AMD zum AMD Catalyst 13.11 Beta V1:

Unterstützung von neuen Grafikkarten

  • AMD Radeon R9 280X
  • AMD Radeon R9 270X
  • AMD Radeon R7 260X
  • AMD Radeon R7 250
  • AMD Radeon R7 240

Folgende Probleme sind im Treiber behoben worden:

  • [383176] System hang up when startx after setting up an Eyefinity desktop
  • [384193] Permission issue with procfs on kernel 3.10
  • [373812] System hang observed while running disaster stress test on Ubuntu 12.10
  • [383109] Hang is observed when running Unigine on Linux
  • [383573] AC/DC switching is not automatically detected
  • [383075] Laptop backlight adjustment is broken
  • [383430] Glxtest failures observed in log file with forcing on Anti-Aliasing
  • [383372] Cairo-dock is broken
  • [378333] Severe desktop corruption is observed when enabled compiz in certain cases
  • [384509] glClientWaitSync is waiting even when timeout is 0
  • [382494] C4Engine get corruption with GL_ARB_texture_array enabled

Link: AMD Catalyst™ 13.11 LINUX Beta V1 Driver Release Notes

Eine kleine Bitte habe ich: Wenn irgendwelche Probleme mit dem Treiber auftauchen, scheut euch nicht mir zu berichten (Ich nehme deutsche und englische Bugreports gerne entgegen). ;-) Ich werde versuchen, soweit es mir möglich ist, den gemeldeten Fehler zu reproduzieren. Zusammen mit den nötigen System-Informationen werde ich mich direkt an die richtige Stelle bei AMD wenden, um den Bug in der nächsten Treiber-Version beheben zu lassen. Danke schön. :-D

Für Benutzer älterer AMD Grafikkarten (Radeon HD Serie 2000 – 4000) wird dringend die Installation dieses Treibers abgeraten. AMD hat einen Legacy-Treiber zur Verfügung gestellt. Mehr Informationen zum Legacy Treiber: http://www.sebastian-siebert.de/2013/01/25/opensuse-amd-catalyst-13-1-legacy-treiber-als-rpm-installieren/

Downloads:

Installationsanleitung:
http://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber#Installation_via_makerpm-amd-Skript

Über das makerpm-amd-Skript

Das Skript makerpm-amd-13.11-betav1.sh ist sehr mächtig, robust und läuft vollautomatisch. Der AMD-Installer wird automatisch heruntergeladen, falls er nicht schon im Verzeichnis liegt. Zudem wird geprüft, ob die Grafikkarte vom Treiber unterstützt wird. Auf Wunsch wird nach dem Bau des RPM-Packages der fglrx-Treiber installiert.

Folgende Argumente können dem Skript übergeben werden:

-b Nur das RPM-Package bauen (Standard)
-c <type> Nur X-Server konfigurieren. Monitor-Typ: single = 1 Monitor, dual = 2 Monitore (Wichtig: Nur ausführen, wenn es Probleme mit der Standardkonfiguration des X-Servers auftreten)
-d Nur den AMD-Installer downloaden
-i Das RPM-Package bauen und installieren bzw. updaten
-kms <yes|no> Kernel-Mode-Setting (KMS) aktivieren oder deaktivieren
-nohw Hardware-Erkennung explizit ausschalten. (z.B. beim Bau in einer VM)
-old2ddriver <yes|no> den alten 2D-Treiber aktivieren oder deaktivieren
-r|–report erstellt ein Report und speichert diese in eine Datei namens amd-report.txt
-u|–uninstall entfernt AMD Catalyst restlos vom System. Zuerst wird das fglrx-Package (falls vorhanden) vom System deinstalliert. Danach werden vorhandene AMD-Dateien und -Verzeichnisse entfernt. Hinweis: Falls das Rebuild-Skript installiert wurde, wird es ebenfalls entfernt und das Initskript /etc/init.d/xdm wiederhergestellt.
-ur|–uploadreport wie Option –report nur zusätzlich wird der Report auf einem NoPaste-Service sprunge.us hochgeladen und gibt bei Erfolg den Link zurück.
-h Die Hilfe anzeigen lassen
-V Version des Skript anzeigen

Hilfe, es funktioniert nicht!

Bitte haltet folgende Regel ein:

  1. Bei der Eingabe der Befehle auf mögliche Tippfehler überprüfen.
  2. Möglicherweise ist die Lösung für das Problem im Wiki vorhanden.
  3. In Kommentaren lesen, ob eine Lösung zu einem Problem bereits existiert.

Wenn keines der o.g. Regel greift, dann könnt ihr mit eurem Anliegen an mich wenden. Damit ich euch helfen kann, müsst ihr erst vorarbeiten. Bitte ladet euch das Skript makerpm-amd-13.11-betav1.sh herunter und erstellt einen Report von eurem System in der Konsole:

su -c 'sh makerpm-amd-13.11-betav1.sh -ur'

Das Skript lädt das Report auf sprunge.us hoch und gibt anschließend einen Link aus. Diesen Link postet ihr in eurem Kommentar zusammen mit einer Beschreibung zu eurem Problem an mich. Ich werde mir euren Report anschauen und Hilfestellung geben, wo evtl. das Problem liegen könnte.

Feedbacks sind wie immer willkommen. :-)

VN:F [1.9.22_1171]
Rating: 10.0/10 (3 votes cast)
VN:F [1.9.22_1171]
Rating: +2 (from 2 votes)
openSUSE - proprietären Grafik-Treiber AMD Catalyst 13.11 Beta V1 als RPM installieren, 10.0 out of 10 based on 3 ratings
Dieser Beitrag wurde in openSUSE veröffentlicht und getaggt , , , , , , , . Ein Lesezeichen auf das Permalink. setzen. Kommentieren oder einen Trackback hinterlassen: Trackback-URL.

48 Kommentare

  1. Denny
    Am 16. Oktober 2013 um 22:23 Uhr veröffentlicht | Permalink

    Hallo Sebastian,
    vielen Dank wieder für Deine Arbeit. Das Script arbeitet problemlos und der neue Treiber läuft bereits.
    Eine Rückmeldung noch:
    Mit dem neuen Treiber stürzt die Virtuelle Machine von VMWare Player 6 mit Windows 7 64bit nicht mehr bei folgender Anwendung ab:
    Raumtool 3D ( http://www.firstinvision.de/aut_de_xhtml-4-produkte.php?entryId=raumtool-3d-28)
    Das passierte, wenn man in die 3D – Modellansicht wechselte, hier bis einschliesslich der letzten Treiber BETA.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 18. Oktober 2013 um 20:29 Uhr veröffentlicht | Permalink

      Hallo Denny,

      danke für dein Feedback. Es freut mich, dass damit dein Problem behoben wurde. Falls du mal irgendwelche Probleme mit diesem Treiber entdeckst, bitte wieder hier melden. Danke.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Denny
        Am 20. Oktober 2013 um 10:07 Uhr veröffentlicht | Permalink

        Hallo Sebastian,
        da ich wahrscheinlich der einzige bin, der diese Kombination überhaupt verwendet und das Problem auch an VMware/Linux liegen könnte, hab ich das nicht gemeldet. Bei standard Software in Linux melde ich Probleme natürlich. Danke, dass DU Dich darum kümmerst.

        Soweit unter oS 12.3 64bit mit KDE 4.11 läuft alles sehr gut und stabil, was ich bislang gesehen hab.
        Ich hab KDE auch auf openGL 3 eingestellt. Konnte aber keine Unterschiede feststellen.

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
  2. Tobias
    Am 18. Oktober 2013 um 17:11 Uhr veröffentlicht | Permalink

    Ich habe endlich eine neue Grafikkarte (7750), meine alte 4850er ist abgeraucht, und kann nun endlich wieder die neusten Treiber ausprobieren! :-) Wie stabil läuft der 13.11-Beta-Treiber so allgemein?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 18. Oktober 2013 um 20:37 Uhr veröffentlicht | Permalink

      Hallo,

      schön dich wieder hier zu sehen. :-) Der aktuelle Beta-Treiber läuft hier auf openSUSE 12.3 + KDE 4.10.5 richtig gut. Bisher ist mir noch keine Macke aufgefallen. Es sieht so aus, dass die gemeldeten Fehler alle behoben wurden. Langzeittest steht noch aus und mein Rechner lief seit der Treiberinstallation durch. KDE-Effekte, 3D-Anwendungen wie auch 3D-Spiele laufen tadellos.

      # uptime 
       20:34    2 Tage 22:17 an,  6 Benutzer,  Durchschnittslast: 0,03, 0,10, 0,12

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Tobias
        Am 19. Oktober 2013 um 14:12 Uhr veröffentlicht | Permalink

        Hallo!

        Danke für die Meldung. Gerade habe ich den Treiber installiert und es läuft bisher alles sehr gut, sogar mit KDE 4.11. Ich freu mich auf den fertigen Treiber und eine neue Version deines Skripts! :)

        Grüße, Tobias

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
  3. Am 18. Oktober 2013 um 21:57 Uhr veröffentlicht | Permalink

    Wann ist denn mit einem neuen nicht-beta-Treiber zu rechnen?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Sebastian
      Am 19. Oktober 2013 um 17:50 Uhr veröffentlicht | Permalink

      Genau das ist mir auch gerade durch den Kopf gegangen…

      VA:F [1.9.22_1171]
      Rating: 5.0/5 (1 vote cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 27. Oktober 2013 um 14:44 Uhr veröffentlicht | Permalink

        Hallo zusammen,

        bisher hat AMD dazu nicht geäußert, wann es die nächste „Nicht-Beta-Treiber“ geben wird. Ich bleibe dran.

        Gruß

        Sebastian

        VN:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
  4. Andreas Emmel
    Am 19. Oktober 2013 um 17:32 Uhr veröffentlicht | Permalink

    Hallo,

    auch bei mir läuft der Treiber Super ( Suse 12.3 KDE 4.11 Kernel 3.11 )

    Also vielen Dank für tolle Arbeit.

    MFG

    Andreas

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  5. tomtomme
    Am 24. Oktober 2013 um 13:57 Uhr veröffentlicht | Permalink

    Did someone test this with xbmc+xvba?? All former drivers that are made for x-server 1.14 had broken xvba-experience due to 100% cpu utilization

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Klaus
      Am 29. Oktober 2013 um 18:24 Uhr veröffentlicht | Permalink

      No change – it’s still broken – at least for Radeon HD 6570.

      Klaus

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  6. Werner D
    Am 27. Oktober 2013 um 11:42 Uhr veröffentlicht | Permalink

    Ich versuche seit einiger Zeit verschiedene fglrx Versionen zu installieren. Früher ging das ja alles ganz gut aber seit 12.3 ist Schluss.

    Ich hab ein Opensuse 12.3, Kernel 3.7.10, KDE 4.10. CPU ist eine AMD dual-core mit entsprechender SB. Die Grafikkarte ist eine HD 6570, sollte also mit dem normal Treiber gehen.

    Der Treiber baut ohne Fehlermeldung und das System startet auch danach. Vor dem bauen und installieren hab ich KMS ausgeschaltet, allerdings schein es auch mit eingeschaltetem KMS nicht zu gehe. Das Problem ist wohl, dass der fglrx Treiber nicht geladen wird und ich kriege folgende Meldungen bei modprobe:

    WARNING: Error inserting amd_iommu_v2 (/lib/modules/3.7.10-1.1-desktop/kernel/drivers/iommu/amd_iommu_v2.ko): No such device
    FATAL: Error inserting fglrx (/lib/modules/3.7.10-1.1-desktop/extra/fglrx.ko): No such device

    Google sagt nicht viel dazu, jedenfalls nichts womit ich was anfangen könnte. Gibts irgendeinen Hinweis?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 27. Oktober 2013 um 14:51 Uhr veröffentlicht | Permalink

      Hallo Werner,

      Bitte einmal ein Report erstellen und den Link zum Report hier posten.

      su -c 'sh makerpm-amd-13.11-betav1.sh -ur'

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  7. Am 27. Oktober 2013 um 22:18 Uhr veröffentlicht | Permalink

    worked for me on tumbleweed but not on 13.1 rc1
    it completeley freezes when it wants to load kde and I can only get to desktop via the failsafe boot option

    here the report
    http://sprunge.us/ADdN

    when I uninstall fglrx everything is fine and kde works with glamor and OpenGL 2.0 and light gaming. strang thing is, that even after uninstall I have those fglrx-things in my log:

    grep fglrx /var/log/Xorg.0.log
    [ 6.625] (==) Matched fglrx as autoconfigured driver 0
    [ 6.625] (==) Matched fglrx as autoconfigured driver 2
    [ 6.625] (II) LoadModule: „fglrx“
    [ 6.628] (WW) Warning, couldn’t open module fglrx
    [ 6.628] (II) UnloadModule: „fglrx“
    [ 6.628] (II) Unloading fglrx
    [ 6.628] (EE) Failed to load module „fglrx“ (module does not exist, 0)

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 12:55 Uhr veröffentlicht | Permalink

      Hello Tomme,

      sorry, for late answer. I am very busy. Can you try to submit the report again? I can not get the report from the URL. Maybe wrong or outdated URL. Thank you.

      Greetings,

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  8. madanyang
    Am 29. Oktober 2013 um 17:54 Uhr veröffentlicht | Permalink

    From time to time I have the folllowing error
    [fglrx:KAS_Mutex_Release] *ERROR* Mutex released without holding it

    By google search I found http://devgurus.amd.com/thread/167582. but accordinng tho the last post Cat 13.11 has solved the issue for him., where as it it not the case in my situation

    fglrx64_xpic_SUSE123-13.20.16-1.x86_64 generated by your makerpm-amd-13.11-betav1.sh
    (makerpm-amd-13.11-betav1.sh – Version 5.33)

    Machine is openSUSE 12.3 kernel 3.7.10-1.16-desktop with intel i7 3770 16 GB Ram and with video card asus HD7950-DC2T-3GD5-V2

    5.883] (**) fglrx(0): NoAccel = NO
    [ 5.883] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
    [ 5.883] (–) fglrx(0): Chipset: „AMD Radeon HD 7900 Series“ (Chipset = 0x679a)
    [ 5.883] (–) fglrx(0): (PciSubVendor = 0x1043, PciSubDevice = 0x0428)
    [ 5.883] (==) fglrx(0): board vendor info: third party graphics adapter – NOT original AMD
    [ 5.883] (–) fglrx(0): Linear framebuffer (phys) at 0xe0000000
    [ 5.883] (–) fglrx(0): MMIO registers at 0xf7e00000
    [ 5.883] (–) fglrx(0): I/O port at 0x0000e000
    [ 5.883] (==) fglrx(0): ROM-BIOS at 0x000c0000
    [ 5.884] (II) fglrx(0): AC Adapter is used

    It doesn’t happen all the time so I can not pinpoint what triggers it.
    Thanks

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 12:59 Uhr veröffentlicht | Permalink

      Hello,

      I try to post a new script with the latest Beta driver (AMD Catalyst 13.11 Beta V6). Maybe this is solved the issue.

      Greetings,

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  9. Klaus
    Am 29. Oktober 2013 um 18:39 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    in Sachen HD 6570 reiht sich 13.11 beta1 nahtlos in die Qualität der vorigen Treiber ein. Der letzte Funktionierende ist 13.3beta3. Siehe auch http://www.sebastian-siebert.de/2013/08/14/opensuse-proprietaeren-grafik-treiber-amd-catalyst-13-8-beta1-als-rpm-installieren/#comment-4238.

    Erst mit 13.11beta6 wird fast wieder alles gut – außer natürlich XVBA – das tut nach wie vor nicht. 13.11beta6 ist aber gefühlt richtig flott unter KDE und Co unterwegs und auch das Thema input latency ist teilweise deutlich reduziert. Siehe auch http://phoronix.com/forums/showthread.php?85998-New-Catalyst-13-11-Beta-Supports-The-R9-290X&s=c9c70cb6a4bab8f6ecfaa55ced28df03&p=366060#post366060

    Klaus

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:11 Uhr veröffentlicht | Permalink

      Hallo Klaus,

      danke für die Info. Ich prüfe das bei mir nochmal mit XvBA.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  10. Bernd
    Am 30. Oktober 2013 um 17:57 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    bei der aktuellen Beta-Version (sowie auch von mir getestet bei der letzten offiziellen Release 13.4) geht die Helligkeitsregelung immer noch nicht im Gegensatz zu früher.

    Hier der Link zum Report: Helligkeitsregelung

    Vielen Dank für deine Mühe!

    Bernd

    P.S.: Nicht irritieren lassen, dass ich angeblich Opensuse 12.2beta benutze. Das wurde irgendwie nie beim Wechsel von beta zum final release überschrieben, obwohl ich die Standard 12.2-Repos nutze und alles up-to-date ist.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Bernd
      Am 30. Oktober 2013 um 17:58 Uhr veröffentlicht | Permalink

      Und wo ist der Link? Hier: http://sprunge.us/QHSd

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 19. November 2013 um 17:15 Uhr veröffentlicht | Permalink

        Hallo Bernd,

        die Helligkeitsregelung sollte eigentlich behoben sein, zumindest bei mir ist es jedenfalls so. Ich werde nachher ein Skript von der letzten Beta-Version von AMD bauen. Dann kannst du es auch nochmal prüfen, ob es evtl. noch so ist.

        Gruß

        Sebastian

        VN:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
  11. Jan
    Am 30. Oktober 2013 um 20:44 Uhr veröffentlicht | Permalink

    Ich habe unter opensuse 13.1 RC1 und dem neuen AMD Treiber
    mit einee on-board Grafik AMD A8-6600K 8192 MB Radeon HD8570D
    ein Problem mit dem yast2:
    Das yast Fenster (benutzt wohl Qt4) „zerfaellt“ in zufaellig in
    unlesbare Teile.
    Komischerweise gibt es bei allen anderen Anwendungen keine Probleme.

    Jan

    http://sprunge.us/jBfi

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:16 Uhr veröffentlicht | Permalink

      Hallo Jan,

      so etwas habe ich auch kurzzeitig auf openSUSE 13.1 RC1 gesehen. Hier müsste man die Desktop-Effekte auf eine bestimmte OpenGL-Version hochheben, dann ging es wieder. Ich prüfe, dass auch nochmal nachher mit der Final openSUSE 13.1.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  12. Peter
    Am 31. Oktober 2013 um 18:28 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    oh mein Gott die beta v6 weigert sich ein rpm zu bauen.

    na priml.

    Oh AMD bitte bring uns mal wieder einen Treiber ohne beta und einer der ohne zicken installiert. Danke

    grüße

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:20 Uhr veröffentlicht | Permalink

      Hallo Peter,

      das ist richtig, dass die letzte Beta (AMD Catalyst 13.11 Beta V6) nicht korrekt gebaut wird. Es gab ein großes Kommunikationsproblem zwischen AMD und den Packaging-Script-Maintainer wie mir. Da wurde irgendeine Datei hinzugefügt, die da nicht reingehört. AMD habe ich bereits schon Bescheid gesagt und dabei ist es denen auch aufgefallen. :-?

      Heute Abend gibt es ein neues Skript ohne den Baufehler.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  13. Am 01. November 2013 um 19:55 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    auch von mir vielen Dank für die Arbeit am Skript. Der Treiber wird einwandfrei installiert und läuft mit 64bit-Anwendungen problemlos. Was gerade nicht will, sind 32bit-Anwendungen, wie bspw. Steam. Ich habe schon alle 32bit-Kompatibilitätspakete aus dem Bereich OpenGL/Mesa und Xorg/X11 installiert, die ich finden konnte, aber es bringt nichts.

    Ich teste es auf openSUSE 13.1 RC2 64bit.

    Es wird folgender Fehler angezeigt:

    name of display: :0
    libGL: screen 0 does not appear to be DRI2 capable
    libGL: OpenDriver: trying /usr/lib/dri/updates/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/dri/updates/swrast_dri.so
    libGL: Can't open configuration file /home/buschmann/.drirc: No such file or directory.
    libGL error: failed to load driver: swrast
    display: :0 screen: 0
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

    Skriptreport

    Installierte Pakete

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • tomtomme
      Am 06. November 2013 um 19:54 Uhr veröffentlicht | Permalink

      ich hatte mit dem treiber schon uunter RC1 kein glück. FGLRX installiert nicht vollständig. Das scheint bei dir auch der fall zu sein. Sonst würde er nicht auf den software-rasterizer zurückgreifen (swrast). Hast du schon openGL spiele 32 bit am laufen gehabt? würde mich wundern…
      deinstallier lieber wieder per

      sh makerpm.sh -u

      und probier dann mal ob der oss-treiber für dich taugt. bei mir läuft er schon mit den meisten games, obwohl ich ne hd 7950 hab, deren oss-treiber noch nicht ausgereift is.

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 11. November 2013 um 22:39 Uhr veröffentlicht | Permalink

        32bit-OpenGL-Anwendungen laufen gar nicht. Da es auch noch ein paar andere Probleme gab bin ich vorerst wieder zum offenen radeon-Treiber zurückgekehrt. Beta6 von der AMD-Seite lässt sich ja noch nicht ohne weiteres unter 13.1 installieren. Warte ich halt noch ein wenig.

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:25 Uhr veröffentlicht | Permalink

      Hallo,

      danke für deinen Report. Ich nutze hier auch Steam und habe dort einige Spiele für den Spaß und auch zum Test der neuen Beta-Treiber erworben. Jedoch noch auf openSUSE 12.3 (64-bit). Da laufen die 32-bit Anwendungen problemlos. Nachher teste ich das nochmal mit der finalen openSUSE 13.1 auf einer separaten Partition und versuche es zu reproduzieren.

      Heute Abend gibt es ein neues Skript für AMD Catalyst 13.11 Beta V6.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  14. Chris
    Am 11. November 2013 um 06:08 Uhr veröffentlicht | Permalink

    Ran a system update for Tumbleweed. Ended up with kernel 3.12 and graphic errors up the wazoo due to the new kernel and a proprietary drive meant for the previous kernel.
    Tried running your script but it threw an error when compiling for the 3.12 kernel.

    Here’s the script output: http://pastebin.com/3ZUbb9Jf
    Here’s the report: http://sprunge.us/WNbg

    I know the current version of the script was only designed for up to the 3.11 kernel but thought it couldn’t hurt to let you know.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Chris
      Am 11. November 2013 um 06:17 Uhr veröffentlicht | Permalink

      Script output in what seems to be the preferred place: http://sprunge.us/QLHT

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 19. November 2013 um 17:31 Uhr veröffentlicht | Permalink

        Hi Chris,

        thank you for the Report. I try to patch the fglrx driver with the latest AMD Catalyst 13.11 Beta V6 today.

        Greetings,

        Sebastian

        VN:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
  15. Peter
    Am 16. November 2013 um 09:33 Uhr veröffentlicht | Permalink

    Hallo Sebastian,
    ich bekomme folgende Fehlermeldung bei der Kompilierung mit Kernel 3.12.

    Used CPUs/Cores for compilation => [ 8 ]

    ********************************************************************************
    * *
    * Kernel: 3.12.0-34.ge8fa6b4-desktop *
    * Source: /lib/modules/3.12.0-34.ge8fa6b4-desktop/build *
    * Include: /lib/modules/3.12.0-34.ge8fa6b4-desktop/source/include *
    * *
    ********************************************************************************

    file /lib/modules/3.12.0-34.ge8fa6b4-desktop/source/include/../arch/x86/include/asm/compat.h says:COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
    /usr/src/kernel-modules/fglrx/2.6.x /Platz/phindela
    rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
    make: Entering directory `/usr/src/linux-3.12.0-34.ge8fa6b4-obj/x86_64/desktop'
    LD /usr/src/kernel-modules/fglrx/2.6.x/built-in.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_agp.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_debug.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_ioctl.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_io.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_pci.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_str.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_iommu.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl.o
    CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_wait.o
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetEffectiveUid':
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:1750:5: error: incompatible types when returning type 'kuid_t' but 'KCL_TYPE_Uid' was expected
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetInitKerPte':
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2624:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2627:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2632:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetPageTableByVirtAddr':
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2691:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2696:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2702:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetPageSizeByVirtAddr':
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2760:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2765:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2771:5: warning: return makes integer from pointer without a cast [enabled by default]
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetEffectiveUid':
    /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:1754:1: warning: control reaches end of non-void function [-Wreturn-type]
    make[3]: *** [/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.o] Error 1
    make[3]: *** Waiting for unfinished jobs....
    make[2]: *** [_module_/usr/src/kernel-modules/fglrx/2.6.x] Error 2
    make[1]: *** [sub-make] Error 2
    make: *** [all] Error 2
    make: Leaving directory `/usr/src/linux-3.12.0-34.ge8fa6b4-obj/x86_64/desktop'

    ******************************
    Build of kernel module failed!
    ******************************

    rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
    /Platz/phindela
    Calling 'depmod -a 3.12.0-34.ge8fa6b4-desktop' this may take a while...

    Summary report:
    ================================================================================

    Kernel => 3.12.0-34.ge8fa6b4-desktop
    Detected => RPM package
    Build => [ FAILURE ]
    Install => [ FAILURE ]

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Peter
      Am 18. November 2013 um 22:34 Uhr veröffentlicht | Permalink

      nebenbei bemerkt geht auch der Download nicht mehr über wget da AMD direktes Downloaden anscheinend abgestellt hat.

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Am 19. November 2013 um 17:37 Uhr veröffentlicht | Permalink

        Hallo Peter,

        ja, AMD hat tatsächlich den Download über die CLI-Tools abgestellt. Aber hey, dann hacken wir doch mal den Server. Mittlerweile kann ich wieder via wget bzw. curl die Treiber herunterladen. :-P

        Neues Skript kommt heute Abend.

        Gruß

        Sebastian

        VN:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VN:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:32 Uhr veröffentlicht | Permalink

      Hallo Peter,

      ich werde heute Abend ein Patch für Kernel 3.12 in den letzten Beta-Treiber von AMD einpflegen. Dann sollte es hoffentlich wieder funktionieren.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  16. Lars
    Am 16. November 2013 um 17:23 Uhr veröffentlicht | Permalink

    1. Wie schon beschrieben, funktioniert das Kompilieren mit 3.12 nicht (wobei laut Phoronix der Ati-Treiber eigentlich schon seit geraumer Zeit 3.12-fix sein sollte).

    2. Und seit der letzten stabilen (uralten) Version funktioniert bei mir der KDE4-„Wunderlampen“-Effekt zum Fenster-Minimieren-/Maximieren nicht mehr, danach ist der gesamte Desktop verhackstückt. Schade, den fand ich sehr nett ;).

    Auf zwei anderen Rechnern habe ich AMD-Hardware < 7000-Serie. Da funktioniert mit aktuellen Kernel- und Mesa-Versionen der freie "Radeon"-Treiber so gut (und in Teilen bereits deutlich besser als der AMD-Treiber), dass ich bereits völlig auf den proprietären Treiber verzichten kann. Leider ist man ab der 7000er-Serie noch nicht so weit, so dass ich hier weiterhin sehr froh über diese hier zur Verfügung gestellten RPMs bin. Danke!

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:34 Uhr veröffentlicht | Permalink

      Hallo Lars,

      danke für dein Feedback. Von welcher openSUSE und KDE Version reden wir hier?

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • Lars
        Am 19. November 2013 um 18:21 Uhr veröffentlicht | Permalink

        OpenSUSE Tumbleweed (Kernel 3.12 und KDE 4.11).
        Ist aber mit der heute erfolgten Veröffentlichung von 13.1 erst einmal hinfällig.

        Bzgl. des KDE-Wunderlampeneffekts – der geht nur mit dem letzten veröffentlichen Nicht-Beta-Treiber. Alle anderen Treiberversionen gehen nicht mehr. D.h. es dürfte auch schon mit früheren KDE-Versionen nicht gegangen sein – habe ich aber nicht mehr so parat.

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        • Am 23. November 2013 um 13:29 Uhr veröffentlicht | Permalink

          Hallo Lars,

          AMD hat nun ein neuen Beta-Treiber veröffentlicht. Ich habe die Wunderlampe da einmal auf openSUSE 12.3 (64-bit) + KDE 4.10 wie auch openSUSE 13.1 (64-bit) + KDE 4.11 getestet. Auf beiden Systemen funktioniert der Wunderlampeneffekt. Kannst du das bei dir auch einmal installieren und mir Feedback dazu geben? Vielen Dank.

          Gruß

          Sebastian

          VN:F [1.9.22_1171]
          Rating: 0.0/5 (0 votes cast)
          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
  17. kai
    Am 18. November 2013 um 10:26 Uhr veröffentlicht | Permalink

    das skript scheint nicht mehr zu funktionieren da es den treiber nicht mehr runterladen kann, auf der amd webseite gibts auch nur noch die amd-catalyst-13.11-beta6 version zum download.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:35 Uhr veröffentlicht | Permalink

      Hallo Kai,

      danke für die Info. Es wird sowieso ein neues Skript geben, dann funktioniert der Download wieder. :-)

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  18. tomtomme
    Am 19. November 2013 um 09:13 Uhr veröffentlicht | Permalink

    mmmh – no fglrx for 13.1 at launch… that is rather unfortunate – again. Many other openSUSE releases before fglrx was not ready at launch…
    Does somebody know when the repo http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/x86_64/ will be populated?
    For gods sake the oss-driver is ok for many use cases now. Maybe Sebastian should throw his work-power also into this, instead into the proprietary department, that seems to get more and more behind…

    Whats your point of view? Just curious…

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 19. November 2013 um 17:41 Uhr veröffentlicht | Permalink

      Hello Tom,

      unfortunately I am very busy in the last days. I try to pull out a new script today with a patch for fglrx on Kernel 3.12. Stay tuned. Thanks.

      Greetings,

      Sebastian.

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  19. Am 06. Dezember 2013 um 17:51 Uhr veröffentlicht | Permalink

    Ich habe das Problem das ich seit meinem Neuen Board meine Grafikkarte nicht mehr mit dem Treiber zum laufen bekomme.

    WARNING: Error inserting amd_iommu_v2 (/lib/modules/3.7.10-1.16-desktop/kernel/drivers/iommu/amd_iommu_v2.ko): No such device
    FATAL: Error inserting fglrx (/lib/modules/3.7.10-1.16-desktop/extra/fglrx.ko):

    das ist der Fehler, die installation mit Deinem Script geht reibungslos.

    nur den treiber laden will er offenbar nicht :(

    weiss Jemand Rat ?

    gruss Sascha

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 21. Dezember 2013 um 15:03 Uhr veröffentlicht | Permalink

      Hallo Sascha,

      gehe zu meinem neuesten Artikel zum AMD Catalyst Treiber und installiere ihn über das Skript nochmal. Sollte es nicht funktionieren, dann erstelle bitte ein Report. Anleitung steht im Artikel. Ich kann sonst mit deinen Informationen nichts anfangen.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)

Einen Kommentar hinterlassen

Ihre E-Mail wird niemals veröffentlicht oder weitergegeben. Erforderliche Felder sind mit * markiert

Sie können diese HTML-Tags und -Attribute verwenden <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*
*

:wink: :-| :-x :twisted: :) 8-O :( :roll: :-P :oops: :-o :mrgreen: :lol: :idea: :-D :evil: :cry: 8) :arrow: :-? :?: :!: