openSUSE 11.2 – proprietären Grafik-Treiber ATI Catalyst 10.1 als RPM installieren

Hinweis: Dieser Artikel ist veraltet. Ein neuer Artikel befindet sich hier: openSUSE 11.2 – proprietären Grafik-Treiber ATI Catalyst 10.2 als RPM installieren

Es gibt 2 Wege den Bau des RPM-Packages durchzuführen.

  1. das RPM mit dem Skript makerpm-ati-10.1.sh bauen (empfohlen)
  2. das RPM manuell bauen (für Fortgeschrittene)

Der Vorteil zu Punkt 1: man muss sich nicht um die nötigen Packages für den Bau kümmern und man spart sich die Tipparbeit, die Zeit und die Nerven. ;-)

Alle genannten Schritte müssen in der Konsole im Root-Modus ausgeführt werden. Es wird empfohlen, die Installation des RPM-Package „fglrx“ im Runlevel 3 durchzuführen.

Vorhandene fremde fglrx-Treiber sind auf jedenfall zu deinstallieren, sonst kommt es zu Konflikten bei der Installation dieses selbstgebauten RPM-Package.

RPM mit dem Skript bauen

Das Skript makerpm-ati-10.1.sh habe ich stark erweitert, ist sehr robust und läuft jetzt vollautomatisch. Der ATI-Installer wird automatisch heruntergeladen, falls er nicht schon im Verzeichnis liegt. Auf dem System werden nach den nötigen Entwicklungspakete geprüft und ggfs. installiert. Auf Wunsch wird nach dem Bau des RPM-Packages dieses ebenfalls installiert.

Folgende Argumente können dem Skript übergeben werden:
-b – Nur das RPM-Package bauen (Standard)
-c – Nur X-Server konfigurieren. Monitor-Typ: single = 1 Monitor, dual = 2 Monitore (Wichtig: Nur ausführen, wenn es Probleme mit der Standardkonfiguration des X-Servers auftreten)
-d – Nur den ATI-Installer downloaden
-i – Das RPM-Package bauen und installieren bzw. updaten
-h – Die Hilfe anzeigen lassen
-V – Version des Skript anzeigen

Downloads:

Empfohlene Vorgehensweise:

1. Das System im Runlevel 3 starten oder wechseln (Alternativ kann man auch diesen Punkt nach Punkt 4 durchführen, falls das Netzwerk in Runlevel 3 nicht verfügbar ist):
Beim Booten: Im Bootmenü den Eintrag von openSUSE 11.2 selektieren und auf der Tastatur die Zahl „3“ und Enter drücken und als „root“ einloggen
Im laufenden System: STRG+ALT+F1 drücken und sich als „root“ einloggen. Danach mit folgendem Befehl in den Runlevel 3 wechseln:

init 3

2. Das Skript herunterladen:

wget http://www.sebastian-siebert.de/downloads/makerpm-ati-10.1.sh

3. Die Prüfsummendatei herunterladen:

wget http://www.sebastian-siebert.de/downloads/makerpm-ati-10.1.sh.sha1

4. Die Prüfsummendatei gegen das Skript prüfen:

sha1sum -c makerpm-ati-10.1.sh.sha1

Idealerweise sollte folgende Ausgabe erscheinen, andernfalls stimmt etwas mit dem heruntergeladenen Skript nicht:

makerpm-ati-10.1.sh: OK

5. Die Rechte des Skriptes ändern und ausführbar machen:

chown root:root makerpm-ati-10.1.sh && chmod 744 makerpm-ati-10.1.sh

6. Das Skript mit dem Argument -i ausführen. Das RPM-Package wird im Anschluß automatisch installiert.

./makerpm-ati-10.1.sh -i

7. Den Rechner neustarten:

reboot

Troubleshooting (RPM mit dem Skript bauen):

– Wenn man nach dem Booten die Konsole anstatt den Desktop sieht, dann kann es evtl. an einer fehlerhaften Konfiguration des X-Servers liegen. In diesem Fall bitte als „root“ in die Konsole einloggen und das Skript mit folgendem Parameter ausführen lassen.

Bei einem Monitor (Single-Modus):

./makerpm-ati-10.1.sh -c single

Bei zwei Monitore (Dual-Modus):

./makerpm-ati-10.1.sh -c dual

Danach den Rechner neustarten. Mit etwas Glück funktioniert alles wieder.

RPM manuell bauen

Das ist der etwas schwierigere Teil. Aber nicht unmöglich. :-)

Für den Bau des RPM-Packages werden folgende Entwicklungswerkzeuge bzw. -packages benötigt

  • gcc
  • make
  • patch
  • linux-kernel-header
  • kernel-source
  • kernel-{default,desktop,pae,rt,vanilla,xen}-devel

Beim Kernel-Entwicklungspackage ist zu beachten, dass man die richtige installiert hat. Welchen Kernel zur Zeit auf dem System läuft, kann man in der Konsole abfragen:

uname -r

Bei mir ergibt beispielsweise diese Ausgabe:

2.6.31.8-0.1-default

Also muss im o.g. Fall der Kernel-Entwicklungspackage kernel-default-devel installiert sein.

Folgende Schritte werden auf einem 32bit openSUSE-System durchgeführt:
(64bit openSUSE-System weiter unten)

1. Den Installer des proprietären Treiber von ATI herunterladen:
http://support.amd.com/us/gpudownload/Pages/index.aspx

2. Das System im Runlevel 3 starten und als „root“ einloggen oder per init 3 wechseln.

3. Den Bau des RPM-Packages anstoßen:

sh ./ati-driver-installer-10-1-x86.x86_64.run --buildpkg SuSE/SUSE112-IA32

3a. Das RPM-Package installieren (Neuinstallation):

rpm -ihv fglrx_7_4_0_SUSE112-8.69*.rpm

3b. Das RPM-Package installieren (Update). Bedauerlicherweise muss man das Argument –force mitgeben (bedankt euch bei ATI), denn der RPM-Paketmanager geht hier sonst von einem veralteten Package aus und verweigert die Installation bzw. das Update:

rpm -Uhv --force fglrx_7_4_0_SUSE112-8.69*.rpm

4. Den Rechner neustarten:

reboot

Folgende Schritte werden auf einem 64bit openSUSE-System durchgeführt:

1. Den Installer des proprietären Treiber von ATI herunterladen:
http://support.amd.com/us/gpudownload/Pages/index.aspx

2. Das System im Runlevel 3 starten und als „root“ einloggen oder per init 3 wechseln.

3. Den Bau des RPM-Packages anstoßen:

sh ./ati-driver-installer-10-1-x86.x86_64.run --buildpkg SuSE/SUSE112-AMD64

3a. Das RPM-Package installieren (Neuinstallation):

rpm -ihv fglrx64_7_4_0_SUSE112-8.69*.rpm

3b. Das RPM-Package installieren (Update). Bedauerlicherweise muss man das Argument –force mitgeben (bedankt euch bei ATI), denn der RPM-Paketmanager geht hier sonst von einem veralteten Package aus und verweigert die Installation bzw. das Update:

rpm -Uhv --force fglrx64_7_4_0_SUSE112-8.69*.rpm

4. Den Rechner neustarten:

reboot

Troubleshooting (RPM manuell bauen):

– Wenn man nach dem Booten die Konsole anstatt den Desktop sieht, dann kann es evtl. an einer fehlerhaften Konfiguration des X-Servers liegen. In diesem Fall bitte als „root“ in die Konsole einloggen und folgende Schritte durchführen.

1. X-Server-Konfiguration verschieben, falls vorhanden:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

2. Von SaX2 eine neue Konfigurationsdatei erzeugen lassen:

sax2 -a

3. Die Konfigurationsdatei von aticonfig für die Nutzung des fglrx-Treibers modifizieren lassen.

3a. Bei einem Monitor (Single-Modus):

aticonfig --initial --input=/etc/X11/xorg.conf

3b. Bei zwei Monitore (Dual-Modus):

aticonfig --initial=dual-head --input=/etc/X11/xorg.conf

Ich hoffe, dass ich das Thema komplett abgedeckt und nicht doch noch irgendetwas vergessen habe. Ich würde mich für Feedbacks sehr freuen. :-)

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
Dieser Beitrag wurde in openSUSE veröffentlicht und getaggt , , , , . Ein Lesezeichen auf das Permalink. setzen. Trackbacks are closed, but you can post a comment.

14 Kommentare

  1. Igor Neiva Camargo
    Am 31. Januar 2010 um 10:26 Uhr veröffentlicht | Permalink

    Super! Jetzt funktioniert! So einfach war es noch nie…
    Vielen Dank!

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  2. Volker
    Am 02. Februar 2010 um 10:38 Uhr veröffentlicht | Permalink

    Hallo Sebastian,
    zwei Fragen vor einem neuen Versuch.

    Vorhandene fremde fglrx-Treiber sind auf jedenfall zu deinstallieren

    wie finde ich die – über Yast software suchen – finde ich nichts

    Bei zwei Monitoren Skript so starten

    ./makerpm-ati-10.1.sh -i -c dual

    Gruss Volker

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 02. Februar 2010 um 15:11 Uhr veröffentlicht | Permalink

      Hallo Volker,

      wenn du in YaST keine fremde fglrx-Package findest, dann hast du folglich auch keine und die Deinstallation erübrigt sich. (Logisch, oder?) Somit dürfte die Installation vom Skript generierte fglrx-RPM-Package nichts im Wege stehen. ;-)

      In deinem Fall würde ich es in 3 Schritten erledigen. Denn die X-Server-Konfiguration macht man in der Regel nur einmal. Deine Kombination ist zwar in der Skript-Version 2.0 möglich, jedoch wird das Skript die RPM nicht bauen, sondern gleich zur X-Server-Konfiguration übergehen. Also faktisch wäre es in dieser Kombination ein Bug und sollte so nicht ausgeführt werden. :-)

      Der -c Parameter wird nun abgefangen, wenn andere Parameter wie -b, -d, -i angegeben wird. Das aktualisierte Skript steht nun in der Version 2.1 zum Download (Link wie o.g.).

      1. Schritt (RPM bauen und installieren/updaten):
      ./makerpm-ati-10.1.sh -i

      2. Schritt: Rechner neustarten und in den Runlevel 3 wechseln

      3. Schritt (X-Server konfigurieren):
      ./makerpm-ati-10.1.sh -c dual

      Anschließend wieder per init 5 in den Runlevel 5 wechseln.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  3. Volker
    Am 02. Februar 2010 um 19:29 Uhr veröffentlicht | Permalink

    Hallo Sebastian erstmal vielen Dank für Deine Mühe mit mir – ich kann nur Windows, aber vielleicht lerne ich ein bisschen

    Nach Deinen Anweisungen lief alles prima ab.
    Konnte den PC und den Treiber starten.
    Nach der Einstellung zweiter Monitor – Neustart
    Jetzt lande ich wieder auf der Konsole
    Nur Failsafe möglich.

    Mein Rechner
    BS:Linux 2.6.31.8-0.1-desktop x86_64
    System:openSUSE 11.2 (x86_64)
    4.3.1 (KDE 4.3.1) „release 6
    RV670PRO [Radeon HD 3850]

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 02. Februar 2010 um 22:31 Uhr veröffentlicht | Permalink

      Hallo Volker,

      das ist echt merkwürdig. Kannst du bitte 2 Dateien auf http://de.pastebin.ca/ hochladen und die beiden Links hier posten.

      Zuerst startest du openSUSE ganz normal. Wenn er aufhängt und in der Konsole landet. In der Konsole loggst du dich als root ein und kopierst die Logdatei vom X-Server in eine gesonderte Datei, sonst wird die Logdatei beim nächsten Neustart wieder überschrieben.

      1. Logdatei sichern:
      cp /var/log/xorg.0.log /var/log/xorg.0.log.diagnose

      2. Rechner neustarten und in den Failsafe-Modus starten

      3. Folgende Dateien auf http://de.pastebin.ca/ hochladen:

      /etc/X11/xorg.conf
      /var/log/Xorg.0.log.diagnose

      Dann schaue ich mir mal die Dateien an und kann dir dann näheres sagen, was da schief läuft.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  4. Volker
    Am 07. Februar 2010 um 13:49 Uhr veröffentlicht | Permalink

    Hallo Sebastian,
    nochmal vielen Dank für Deine Mühe mit mir. Schön das es solche Leute wie Dich gibt.
    Nach ein wenig suchen musste ich feststellen meine Grafikkarte hat den Geist aufgegeben – war noch nicht alt. Habe mir eine NVIDIA bestellt – soll einfacher in LINUX sein. Ich werde sehen.
    Viele Grüße Volker

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  5. Enrico
    Am 11. Februar 2010 um 09:44 Uhr veröffentlicht | Permalink

    Hallo Sebastian

    habe versucht den Treiber mit „RPM mit dem Skript bauen“ zu installieren.

    Skript habe ich heruntergeladen.

    Bis level 3 starten geht alles.
    Wenn ich Punk 4 eingebe erhalte ich folgende Meldung:

    makerpm-ati-10.1.sh.sha1: no such file or directory

    Was mache ich falsch? 8-O

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 11. Februar 2010 um 13:07 Uhr veröffentlicht | Permalink

      Hallo Enrico,

      Sowohl makerpm-ati-10.1.sh als auch makerpm-ati-10.1.sh.sha1 müssen im selben Verzeichnis liegen.

      Bitte im Punkt 3 die Datei „makerpm-ati-10.1.sh.sha1“ heruntergeladen. Wichtig: Genauso wie auf dieser Seite abtippen oder kopieren. Bitte auf Tippfehler prüfen

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  6. Enrico
    Am 11. Februar 2010 um 23:00 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    beide Datein habe ich runtergeladen stehen bei mir im Ordner Download.
    Habe beim eintippen auf schreibfehler geachtet.

    In welchen verzeichnis müssen beide stehen?

    Schon mal danke im vorraus :)

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 12. Februar 2010 um 08:06 Uhr veröffentlicht | Permalink

      Hallo Enrico,

      in welchem Ordner die beiden Dateien letztendlich befinden, ist im Prinzip egal und liegt in deinem Ermessen. Wichtig ist nur, dass diese zusammengehören. Denn du möchtest ja auf der sicheren Seite sein und auch sofort wissen, ob der Download des Skriptes „makerpm-ati-10.1.sh“ fehlerfrei war oder das Skript nicht auf irgendeine Weise manipuliert wurde. Daher die Überprüfung in Punkt 4. :-)

      Wenn du alles hast, dann geht es ab in den Root-Modus im Runlevel 3. Dann wechselst du in deinen Download-Ordner und machst dann mit dem Punkt 4 weiter. Sobald du das Skript angestoßen hast und die RPM installiert wurde, befindet sich in deinem Download-Verzeichnis auch deine gebaute RPM-Package. Diese RPM-Package kannst du später bei Bedarf (z.B. bei einem Kernel-Update) nochmals installieren/updaten.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  7. Enrico
    Am 12. Februar 2010 um 17:51 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    heute hat alles geklappt.

    Nochmal danke für die Hilfe. :mrgreen:

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
  8. Jean
    Am 15. Februar 2010 um 20:48 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    Vielen Dank für das Skript, mit dem fglrx Treiber hatte ich bisher schon einige Probleme, und da ich mit Linux noch nicht ganz firm bin bestand meine Standard Lösung bisher aus ‚System wieder drüber installieren‘.
    Also hier mein jetziges Problem.

    Ich habe alles so gemacht wie beschrieben, (also zu Punkt 1.). Allerdings hat sich in der Konsole meine WLAN Verbindung geschlossen, und das Skript war nicht in der Lage die nötigen packages nachzuladen. Danach komme ich nur noch in die Konsole.
    Wenn ich etwa mit ’startx‘ versuche einen X-Server zu starten, gibt er Fehlermeldungen aus.
    Ich habe das Skript bereits ein weiteres mal, (diesmal mit LAN-Kabel) ausgeführt, und es gab keine Fehler, aber nach wie vor das gleiche Problem: Nur Konsole.

    Irgendwelche Ideen? Sonst werde ich wieder drüber installieren und weiterhin auf fglrx verzichten müssen.

    Ich hoffe ich k0nnte mein Problem veranschaulichen, und dass wir gemeinsam auf eine Lösung kommen.

    Herzlichen Dank schon mal im voraus
    Grüsse

    Jean

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 15. Februar 2010 um 23:56 Uhr veröffentlicht | Permalink

      Hallo Jean,

      gehe ich richtig von der Annahme aus, dass das RPM-Package vom Skript korrekt gebaut und installiert wurde?

      Wenn ja, dann könnte es bei dir ein Problem mit dem X-Server und der automatischen Konfiguration geben. In diesem Fall musst du die Konfigurationsdatei /etc/X11/xorg.conf erstellen lassen.

      Schau mal oben im Artikel unter „Troubleshooting (RPM mit dem Skript bauen)“. Dort habe ich ein Lösungshinweis geschrieben. Diesen Schritt bitte im Runlevel 3 mal ausführen. Das könnte unter Umständen dein Problem lösen.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  9. Lutz Lennardt
    Am 02. April 2010 um 08:22 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    danke für das Treiber-Skript. Es hat einwandfrei funktioniert.

    Gruß
    Lutz

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

Einen Kommentar hinterlassen

Ihre E-Mail wird niemals veröffentlicht oder weitergegeben. Erforderliche Felder sind mit * markiert

Sie können diese HTML-Tags und -Attribute verwenden <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*
*

:wink: :-| :-x :twisted: :) 8-O :( :roll: :-P :oops: :-o :mrgreen: :lol: :idea: :-D :evil: :cry: 8) :arrow: :-? :?: :!: