openSUSE 11.3 – KDE SC 4.5.4

KDE SC 4.5.4 wurde veröffentlicht und die Pakete stehen zum Download für openSUSE bereit. Außerdem wird empfohlen, wie auch in der Ankündigung auf KDE 4.5.4 zu aktualisieren.

Folgende KDE-Komponenten wurden in KDE 4.5.4 aktualisiert:

  • Plasma Desktop
  • Netbook Workspace
  • KDE Anwendungen
  • KDE Plattform

Hierzu sind weitere Fehler behoben worden:

  • kdebase (Dolphin, Konqueror, kxkb)
  • kdelibs (kate, kdecore, kdesu, khtml, kio, kioslave)

Changelog: KDE SC 4.5.4

Wichtiger Hinweis:
Wer bereits nach der unten beschriebenen Anleitung das Repo http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/ eingebunden und aktiviert hat, muss lediglich in YaST im KDE-4.5-Repo auf “Switch system packages” klicken oder per zypper mit einem Repo-Alias ein “Upgrade” durchführen:

zypper dup -r "KDE_4.5"

Um die Lesbarkeit zu erhöhen wurde der Name der Repository geändert. Anstatt “KDE_4.5.x” wird jetzt “KDE_4.5″ hier im Artikel beschrieben.

Für alle anderen, die das Repo noch nicht eingebunden haben, empfehle ich die folgende Anleitung.


Installation (YaST2):

  1. YaST2 starten.
  2. Im Menü Konfiguration -> Repositories aufrufen.
  3. Auf Hinzufügen klicken.
  4. “URL angeben” wählen und auf Weiter klicken.
  5. Repository-Name eingeben: KDE 4.5
  6. URL des KDE-Repo für openSUSE 11.3 eingeben: http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/
  7. Auf Weiter klicken.
  8. Das erstellte Repository “KDE 4.5″ auswählen und die Priorität auf z.B. 50 ändern.
  9. Auf Okay klicken, um die Verwaltung der Software-Repository zu schließen. Ggfs. den GPG-Schlüssel vom Repo importieren.
  10. In YaST2 dann auf Anzeigen -> Installationsquellen bzw. auf den offenen Tab Installationsquellen klicken.
  11. Auf der linken Seite das “KDE 4.5″-Repo auswählen.
  12. Im blauen Textfeld auf Switch system packages klicken.
  13. Abschließend auf Akzeptieren klicken. Sollte ein Dialogfenster bezüglich des NetworkManager auftauchen, so handelt es sich um ein veraltetes Package (Sprachdatei) und kann gelöscht werden. Das Pendant zum gelöschten Package wird dennoch installiert.
  14. Rechner neustarten und KDE 4.5.4 genießen.

Installation (zypper):

  1. KDE-Repo mit einem Alias hinzufügen:
    zypper ar -f "http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/" "KDE_4.5"
  2. Priorität des KDE-Repo erhöhen:
    zypper mr -p 50 "KDE_4.5"
  3. Upgrade von KDE durchführen:
    zypper dup -r "KDE_4.5"
  4. Rechner neustarten und KDE 4.5.4 genießen.

Have a lot of fun! ;-)

VN:F [1.9.22_1171]
Rating: 10.0/10 (3 votes cast)
VN:F [1.9.22_1171]
Rating: +4 (from 4 votes)
openSUSE 11.3 - KDE SC 4.5.4, 10.0 out of 10 based on 3 ratings
Dieser Beitrag wurde in openSUSE veröffentlicht und getaggt , , , , . Ein Lesezeichen auf das Permalink. setzen. Trackbacks are closed, but you can post a comment.

18 Kommentare

  1. Am 03. Dezember 2010 um 11:22 Uhr veröffentlicht | Permalink

    Hallo!
    Wie immer eine super Anleitung!

    Kleiner Tipp:
    Nicht wundern in der About-Box von KDE wird nach dem Upgrade weiterhin 4.5.3 als Version angezeigt, da haben die Entwickler wohl etwas vergessen zu ändern! :)
    Das System läuft aber definitiv mit KDE SC 4.5.4

    LG krebsi83

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 03. Dezember 2010 um 13:34 Uhr veröffentlicht | Permalink

      Hallo krebsi83,

      das Problem wurde bereits behoben. :-) Bitte nochmal updaten.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
    • Am 03. Dezember 2010 um 21:18 Uhr veröffentlicht | Permalink

      Ja du hast recht! Nach Update steht nun auch Version 4.5.4 in der Abou-Box :-) THX!

      VA:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  2. János
    Am 03. Dezember 2010 um 15:16 Uhr veröffentlicht | Permalink

    Update von KDE 4.5.3 auf 4.5.4 unter OpenSuse 11.2 wegen fehlschlagender Auflösung von Abhängikeiten nicht möglich. Die Datei liblzma.so.5, von libkdecore4 4.5-43.1 benötigt, wird von keiner Installationsquelle angeboten. :roll:

    Ausserdem nerven die ewigen Änderungen der Reporitories. Kann man sich denn nicht auf ein dauerhaftes System einigen?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 03. Dezember 2010 um 16:16 Uhr veröffentlicht | Permalink

      Hallo János,

      Oh Schreck, sag jetzt bloß nicht, du hast das Repo vom Hersteller (Vendor) openSUSE-Factory eingebunden?! Wenn ja, dann sofort den Vendor auf openSUSE 11.2 abändern! Du machst sonst das System kaputt.

      http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.2/

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • János
        Am 03. Dezember 2010 um 16:47 Uhr veröffentlicht | Permalink

        http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.2/ ergibt den selben Abhängikeitsfehler.

        Ebenfalls eingebunden: ftp://ftp5.gwdg.de/pub/opensuse/repositories/KDE%3a/Extra/openSUSE_11.2_KDE_Release_45/ und ftp://ftp5.gwdg.de/pub/opensuse/repositories/KDE:/UpdatedApps/openSUSE_11.2/

        An Packman kann es hoffentlich nicht liegen.

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
        • Am 03. Dezember 2010 um 17:07 Uhr veröffentlicht | Permalink

          Okay, nach dem du es ausgeschlossen hast, dass es am Repo liegt, habe ich mal nach dem Package geschaut. Tatsächlich taucht in den Abhängigkeiten liblzma.so.5 anstatt liblzma.so.0 auf.

          Ich habe ein Bugreport aufgemacht und dort das KDE-Team von openSUSE gebeten, sich das mal anzuschauen.

          Gruß

          Sebastian

          VN:F [1.9.22_1171]
          Rating: 0.0/5 (0 votes cast)
          VN:F [1.9.22_1171]
          Rating: 0 (from 0 votes)
          • János
            Am 03. Dezember 2010 um 17:16 Uhr veröffentlicht | Permalink

            THX für die Mühe und den Bugreport. :-D Vermutlich wäre ich spätestens beim Versuch einen brauchbaren Bugreport zu schreiben kläglich gescheitert. Mein Englisch ist sagen wir mal etwas sehr eingerostet.

            Sobald das Update bei mir geklappt hat, gebe ich hier laut.

            VA:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VA:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
          • Am 03. Dezember 2010 um 17:21 Uhr veröffentlicht | Permalink

            Kein Problem, dass war schnell gemacht. ;-)

            Gruß

            Sebastian

            VN:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VN:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
          • János
            Am 06. Dezember 2010 um 12:52 Uhr veröffentlicht | Permalink

            Wie versprochen, hier die Erfolgsmeldung. Gestern abends hat das Update ohne Abhängigkeitsprobleme geklappt. KDE läuft wie Sau, zumindest gefühlt um einiges flotter und flüssiger als der 4.5.3.

            Grüße aus dem “wilden Osten” :wink:
            János

            VA:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VA:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
          • Am 06. Dezember 2010 um 13:34 Uhr veröffentlicht | Permalink

            Hallo János,

            vielen Dank für deine Rückmeldung. Ich habe soeben auch den Bugreport als behoben eingestuft und geschlossen.

            Gruß

            Sebastian

            VN:F [1.9.22_1171]
            Rating: 0.0/5 (0 votes cast)
            VN:F [1.9.22_1171]
            Rating: 0 (from 0 votes)
  3. János
    Am 03. Dezember 2010 um 16:34 Uhr veröffentlicht | Permalink

    Repo-URL: ftp://ftp5.gwdg.de/pub/opensuse/repositories/KDE:/Release:/45/openSUSE_11.2/

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 03. Dezember 2010 um 16:38 Uhr veröffentlicht | Permalink

      Kannst du bitte überprüfen, ob ggfs. der Mirror defekt ist und vorerst einen anderen Mirror ausprobierst. Danke.

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  4. Mario
    Am 04. Dezember 2010 um 13:40 Uhr veröffentlicht | Permalink

    Alles so gemacht, nur nach dem Update erscheint nur ein schwarzer Bild mit einer Maus.
    Sonst nichts. TWM und ICEWM gehen. Alle Abhänigkeiten ok. Ach ja es erscheint kurz
    die Forschrittsanzeige und dann der schwarze Bildschirm.
    Kann mir keinen Reim daraus machen.

    Gruss mario

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 04. Dezember 2010 um 15:21 Uhr veröffentlicht | Permalink

      Hallo Mario,

      ich habe ein paar Fragen an dich:

      Welche openSUSE-Version (11.1, 11.2 oder 11.3) verwendest du?
      Für welchen Prozessortyp (32-bit / IA32 oder 64-bit / AMD64)?
      Welche KDE-Version hattest du vorher drauf?
      Welche Grafikkarte verwendest du?
      Benutzt du proprietäre Treiber von AMD/ATI oder NVIDIA? Wenn ja, welche Version?

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
      • mario
        Am 17. Januar 2011 um 19:58 Uhr veröffentlicht | Permalink

        Hallo,

        sorry das ich erst jetzt antworte. Berufsstress. Nun ich habe open suse 11.3 64 BIT drauf und bin nach deiner Anleitung von KDE 4.4.1 (glaube ich) auf KDE 4.5.5 upgedatet. Graifkarte ATI 4670 treiber war radeon. Wie gesagt twm usw gehen.

        Gruss mario

        VA:F [1.9.22_1171]
        Rating: 0.0/5 (0 votes cast)
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)
  5. Am 20. Dezember 2010 um 10:07 Uhr veröffentlicht | Permalink

    Hallo Sebastian,

    Das KDE Update hat am 2010-12-18 einwandfrei geklappt. Nur die Energieverwaltung und die Geräteüberwachung waren nach dem Update zweimal vorhanden (einmal im Systemabschnitt).
    Bis jetzt funktioniert’s unter openSUSE 11.2 64bit (incl. Catalyst 10.12). Notebook ist ein Lenovo Thinkpad R500.

    MfG
    Jan

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)
    • Am 20. Dezember 2010 um 14:56 Uhr veröffentlicht | Permalink

      Hallo Jan,

      hört sich soweit gut an. Ist die Energieverwaltung und die Geräteüberwachung jetzt noch doppelt vorhanden oder nicht mehr?

      Gruß

      Sebastian

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)

Einen Kommentar hinterlassen

Ihre E-Mail wird niemals veröffentlicht oder weitergegeben. Erforderliche Felder sind mit * markiert

*
*

Sie können diese HTML-Tags und -Attribute verwenden <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

:wink: :-| :-x :twisted: :) 8-O :( :roll: :-P :oops: :-o :mrgreen: :lol: :idea: :-D :evil: :cry: 8) :arrow: :-? :?: :!: